Can't get an IP address - IP Driver Error Code 2

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

cgrablew

Thread Starter
Joined
Jun 30, 2005
Messages
3
I can't connect my Dell Laptop to my home wireless or wired network. It sees the Wireless network and connects but it never receives an IP address, so it can't access the Internet. I've tried uninstalling TCP/IP, the network cards and tried connecting directly to the cable modem without any luck. This PC worked fine before my wife took it on a trip. She says that the only thing she did was try to access a wireless network on her return trip. In researching the problem I tried deleting the WINSOCK & WINSOCK2 entries from the registries but it didn't help. My guess is that I have corrupted file somewhere. When doing a ipconfig, I get an IP 'Driver, error code 2" error. Me and 2 other techie friends spent several hours trying to fix the problem to no avail. Has anyone else run across this problem and how did you fix it?
 

cgrablew

Thread Starter
Joined
Jun 30, 2005
Messages
3
Yes I am using XP. I have tried deleting the WINSOCK & WINSOCK2 entries in the registry but it didn't work. I tried doing IPCONFIG /ALL again and got a different message: An Internal Error Occurred. The request is not support. Unable to query host name. Please contact Microsoft.
 

cgrablew

Thread Starter
Joined
Jun 30, 2005
Messages
3
Hi,

I've tried the netdiag /test:winsock but I get an error saying it can't access the TCP/IP entries in the registry. Any ideas on what this may be?

Thanks
 
Joined
Nov 2, 2002
Messages
22,468
Might try sfc /scannow

Saw a few posts where resetting the IP stack didn't work but might want to give it a try:

netsh int ip reset [ log_file_name ]

the log_file_name needs to be specified.
e.g. - netsh int ip reset ip_reset.txt
 
Joined
May 14, 2005
Messages
6
To repair Winsock if you have Windows XP Service Pack 2 (SP2) installed, type netsh winsock reset at the command prompt, and then press ENTER.

Note: Restart the computer after you run this command. Additionally, for computers that are running Windows XP SP2, there is a new netsh command that can rebuild the Winsock key. For more information, visit the following Web site:
http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2netwk.mspx
 
Joined
Jul 13, 2005
Messages
28
I have tried everything I know and two other guys in the office have as well. Any ideas? The only things I can add are when the machine boots it seems to hang (I can do some functions command prompt but no access to network properties or exploring computer) then it goes blank, and when it reloads everything is running. I installed a copy of Symantec Antivirus Corporate 10, and then tried to update the defs manually with no luck. The NIC passed all bios tests and the Dell32 tests. The lights are on on the NIC but the OS reports it is disconnected. Tried all above suggestions. HELP!!!!
 
Joined
Mar 3, 2005
Messages
60
You can rebuild your tcp/ip stack by the following command line...
netsh winsock reset catalog<Enter>
 
Joined
Jul 13, 2005
Messages
28
Tried both with a reboot in between each and still no luck. I am at the point to reload OS, but I would love to find the fix.
 
Joined
Nov 2, 2002
Messages
22,468
"Tried both with a reboot in between each and still no luck. " - What exactly did you try.

Before a reload from scratch, and since you can boot, you might try either a reinstall or repair install. If it works it would sure save a lot of time.

FOR A RE-INSTALL
Start WindowsXP
Go to the location of your source files
Run WINNT32 /unattend
This is probably the fastest and easiest

FOR A REPAIR INSTALL
1. Insert and boot from your WindowsXP CD
2. At the second R=Repair option, press the R key
3. This will start the repair
4. Press F8 for I Agree at the Licensing Agreement
5. Press R when the directory where WindowsXP is installed is shown. Typically this is C:\WINDOWS
6. It will then check the C: drive and start copying files
7. It will automatically reboot when needed. Keep the CD in the drive.
8. You will then see the graphic part of the repair that is like during a normal install of XP (Collecting Information, Dynamic Update, Preparing Installation, Installing Windows, Finalizing Installation)
9. When prompted, click on the Next button
10. When prompted, enter your XP key
11. Normally you will want to keep the same Workgroup or Domain name
12. The computer will reboot
13. Then you will have the same screens as a normal XP Install
14. Activate if you want (usually a good idea)
15. Register if you want (but not necessary)
16. Finish
17. At this point you should be able to log in with any existing accounts.
 
Joined
Jul 13, 2005
Messages
28
Sorry Bob. I tried your suggestions and then the thread after yours. Rebooting in between of course. I am trying the re-install option now!
 
Joined
Jul 13, 2005
Messages
28
The automated repair option took care of my problems. Had issues getting the unattended to work. Looks like a bad NIC and somehow that caused the IP issues. Everything is working and now the NIC fails the Dell tests. Thanks! THis was my first use of this board and I will be back!
 
Joined
Apr 3, 2007
Messages
1
REALLY REINSTALLING TCP/IP
Complete destruction and restoration of dead TCP/IP stack
Recovery from fatal failure or partial or complete corruption of TCP/IP.
For virus related problems, please consult tcpip.sys to ensure it is not a corrupt version before following these steps.

This solution is an alternative to reinstalling by partial method or by using winnt /unattend which I very much wanted to avoid.

Here is the hardcore method when nothing else is working. I have cobbled together these suggestions through various forums to offer them here as a concise solution. There are no guarantees! Back up anything relevant and set a system restore point to cover your ***. I discovered this method after all other solutions failed.


Related error messages:
"TCP/IP network transport is not installed" error message from active sync
TCP/IP driver missing from devmgmt.msc showing hidden devices
ipconfig produces immediate failure message :
Windows IP Configuration
An Internal error occured: The request is not supported.
Please contact Microsoft Product Support Services for further help.
Additional information: Unable to query host name.
"the specified device instance handle does not correspond to a present device" message regarding DHCP service in services.msc
net start tcpip >>> fails with system error 2, The system cannot find the file specified
ping error: "Unable to contact IP driver, error code 2"
Repair Local Area Connection: Failed to query TCP/IP settings of the connection. Cannot proceed.
"Tcp/ip Protocol Driver Service Failed To Start, system cannot find the file specified"
"The TCP/IP Protocol Driver service failed to start due to the following error: The system cannot find the file specified"


Failed repair methods:
netsh int ip reset resetlog.txt >>> no effect
non-full reinstall of TCP/IP using only the have disk method. >>> no effect
netsh Winsock reset >>> no effect
http://www.snapfiles.com/get/winsockxpfix.html >>> no effect
reinstalling network card >>> no effect

MY SOLUTION:::

Step #1
Full uninstall of TCP/IP ... no ********.
----------------------------------------------------------------------
These steps are copied from http://support.microsoft.com/kb/325356
11. Locate the Nettcpip.inf file in %winroot%\inf, and then open the file in Notepad.
12. Locate the [MS_TCPIP.PrimaryInstall] section.
13. Edit the Characteristics = 0xa0 entry and replace 0xa0 with 0x80.
14. Save the file, and then exit Notepad.
15. In Control Panel, double-click Network Connections, right-click Local Area Connection, and then select Properties.
16. On the General tab, click Install, select Protocol, and then click Add.
17. In the Select Network Protocols window, click Have Disk.
18. In the Copy manufacturer's files from: text box, type c:\windows\inf, and then click OK.
19. Select Internet Protocol (TCP/IP), and then click OK.
Note This step will return you to the Local Area Connection Properties screen, but now the Uninstall button is available.
20. Select Internet Protocol (TCP/IP), click Uninstall, and then click Yes.
RESTART

succesfull uninstallation of TCP/IP will remove numerous keys from the registry including
HKLM/system/CurrentControlSet/services/tcpip
HKLM/system/CurrentControlSet/services/dhcp
HKLM/system/CurrentControlSet/services/dnscache
HKLM/system/CurrentControlSet/services/ipsec
HKLM/system/CurrentControlSet/services/policyagent
HKLM/system/CurrentControlSet/services/atmarpc
HKLM/system/CurrentControlSet/services/nla
These represent various interconnected and interdependant services.

For good measure you should delete the following keys before reinstalling TCP/IP in step #2
HKLM/system/CurrentControlSet/services/winsock
HKLM/system/CurrentControlSet/services/winsock2

Step #2
Reinstall of TCP/IP
----------------------------------------------------------------------
Following the above substep #13, replace the 0x80 back to 0xa0, this will eliminate the related "unsigned driver" error that was encountered during the uninstallation phase.

Return to "local area connection"> properties > general tab > install > Protocol > TCP/IP

You may receive an "Extended Error" failure upon trying to reinstall the TCP/IP, this is related to the installer sub-system conflicting with the security database status.

to check the integrity of the security database
esentutl /g c:\windows\security\Database\secedit.sdb

There may be a message saying database is out of date
first try the recovery option
esentutl /r c:\windows\security\Database\secedit.sdb

this did not work for me, I needed the repair option
esentutl /p c:\windows\security\Database\secedit.sdb

rerun the /g option to ensure that integrity is good and database is up to date.

Now return to the "local area network setup"
choose install > protocol > tcp/ip and try again

reboot.
worked for me.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top