1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Can't get rid of Local Disk

Discussion in 'Windows XP' started by skotwarr, Mar 21, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. skotwarr

    skotwarr Thread Starter

    Joined:
    Mar 21, 2007
    Messages:
    8
    Hi, when I open My Computer, it has a list a couple things:
    Hard Disk Drives
    Drive C: (with a hard drive icon)
    Devices with Removable Storage
    DVD/CD+RW Drive D: (with a CD player icon)
    Other
    Local Disk L: (icon with a drive that has a red circle over it with a white question mark in the red circle)

    I attached an image of My Computer window. I can format it but it is pointless because it has 0 free used space. I thought if I did that maybe I would be able to erase it, but that didn't work either. It doesn't show up in Disk Manager either. I have tried using Partition Magic to delete it, but on reboot it gives me an error 626. I am using Windows XP Home Edition.
    Please help, it is driving me crazy!
    Thank you
     

    Attached Files:

  2. skotwarr

    skotwarr Thread Starter

    Joined:
    Mar 21, 2007
    Messages:
    8
    Any suggestion, please?!
     
  3. Old Rich

    Old Rich

    Joined:
    Jan 17, 2003
    Messages:
    10,254
    Do you have any flash card reader attached?
     
  4. skotwarr

    skotwarr Thread Starter

    Joined:
    Mar 21, 2007
    Messages:
    8
    I did. I read to plug it in and try to eject but my computer read the SD card as a different letter than L: so plugging it back in didn't help. Is there any way to delete it or erase it? I just don't understand why I can't delete it!
     
  5. skotwarr

    skotwarr Thread Starter

    Joined:
    Mar 21, 2007
    Messages:
    8
    has anyone else had this problem and were you able to fix it?
     
  6. skotwarr

    skotwarr Thread Starter

    Joined:
    Mar 21, 2007
    Messages:
    8
    New people on this forum in here now that might have heard or had experience with this problem?
     
  7. AyaDream

    AyaDream

    Joined:
    Apr 29, 2007
    Messages:
    2
    I have an external USB HDD drive that was originally recognised as my G:\ drive. (Actually - I have 2 external USB HDD drives that I swap around as needed using the same USB port/cable). When I boot up the PC without the USB drive attached and then go into My Computer it shows Local Disk G: with a red circle and a white question mark. If I click on the drive I get the "G: refers to a location that is unavailable. etc etc" message.

    Now I thought it had something to do with one of the following:
    1) Acronis True Image & secure zone/backup - so I un-installed it and deleted the Acronis devices in device manager.
    2) NTbackup.exe (MS Backup Utlity) - I removed all references to backing up to g:\ drive.
    3) Linux Ubuntu which I installed on to the external USB HDD drive and booted into by changing the BIOS settings. BIOS settings have now been restored to booting from 1st: Floppy, 2nd: CDROM, 3rd: Primary Master HDD.
    4) System Restore - At one stage I had the system restore function monitoring G: drive as well. - This has been changed back to monitoring only the C: & D: drives by offing all restore capability, rebooting and then instructing the system to only monitor the two internal HDD's
    5) Recycle Bin configuration - I re-configured this by going to Recycle Bin, Properties, and clicking on "Use one setting for all drives" and "Do not remove files to the Recycle Bin. Remove files immediately when deleted".

    None of the above did any good what-so-ever, so in desperation I did a search on the registry and deleted all key values with a references to G:\, shut down and re-booted.

    Guess what?... I've still got a local G: drive with a red circle and a white question mark showing in My Computer. The dam USB drive isn't even attached! (Sorry I'm loosing my cool here!).

    If I look under Computer Management, Disk Management there is no sign of a G: drive. Everest and SiSoftware Sandra XI don't recognise it either. Why does Windows Explorer think it's got a G: drive

    Sorry this post is so long. If anybody can help it would be much appreciated.
    Thanks
    AD
     
  8. AyaDream

    AyaDream

    Joined:
    Apr 29, 2007
    Messages:
    2
    Right, here's how my headache was cured!

    Thanks to being directed to a registry tweak that enables one to (really) see all hidden devices in Device Manager, http://www.theeldergeek.com/show_hidden_devices_in_device_manager.htm, I was able to resolve this problem

    In device manager, I deleted all devices under Disk Drives except current internal HDD drives c: and d:.

    I also deleted ALL Generic Volumes under Storage Volumes and ALL grey-ed out devices under USB Controllers (i.e. ALL the USB Mass Storage Devices). Shut down and re-boot.

    New hardware was found and installed automatically on boot-up and ...Hey Presto... problem resolved!!!

    I then re-attached and detached, one by one, each of my 2 external USB HDD drives and the USB Key Drive that I forgot to tell you about. Windows's My Computer has been correctly identifying each USB device correctly at all stages (i.e. added and removed while PC was up and running and attached & unattached at boot-up.

    Problem solved... Thanks a million!
    ---------------------------------------------------------------

    Thanks to all of you who replied so promptly
    AD
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/553620