1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

can't log in as administrator

Discussion in 'Virus & Other Malware Removal' started by bsgphd, Oct 4, 2008.

Thread Status:
Not open for further replies.
  1. bsgphd

    bsgphd Thread Starter

    Joined:
    Oct 4, 2008
    Messages:
    1
    Hi,
    I have a Dell PC running XP Pro; I don't know the processor type. (Although I could certainly find it if needed.
    The first thing that happened, that may or may not be related, is that, when I went to open the Thunderbird mail client a few days ago it told me it was installing an update and proceeded to do so. (This happens periodically with Thunderbird, and didn't surprise me.) However, after that, I was unable to open Thunderbird. (N.B. this was all on my home computer. On my office computer the next day, I also got a Thunderbird update message and that worked fine after the update.

    On my home computer, I have an "administrator" login that I use for managing the computer and a separate loging that I use for day-to-day computing. (The whole reason for this is that new software can theoretically only be installed by the administrator user, so malware can't install itself --in theory-- when I am logged in as another user.)

    So yesterday I decided I would log in as the administrator in order to completely uninstall Thunderbird and start over. However, when I tried to log in as administrator, I got a whole series of error messages, including the following two:
    "ctfmon.exe: application failed to initialize properly"
    and
    "igfxtray.exe (and other .exe's): The application or DLL c:\windows\system32igfxdev.dll is not a valid Windows image"

    Eventually, I was unable to log in as the administrator. When I tried to log back on as my everyday user, I also got a bunch of error messages but eventually got on, although there was nothing in my tray. When I open applications, they do show up in the tray.

    According to my Internet searches, the igfxtray.exe message, in particular, indicates the presence of a Trojan horse. However, every suggested solution I have found has required one to be logged in as the administrators. (This requirement is frequently implicit; i.e., I can download a "fixer" program, but when I try to run it, I get an error message saying that only the administrator can run that program.) When I ran the "Hijack This" scan it seemed to run but (a) gave me a message that "for some reason, it was not allowed to write to" some file, and then it froze, and had to be killed by the task manager.

    So I'm stuck in a catch-22 -- I can only fix my problem if I log in as administrator, but (one symptom of) my problem is that I can't log in as administrator!

    Any and all help much appreciated, and can certainly be rewarded by a contribution to the hedgehogs!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/756153

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice