Can't send bulk emails?

Fouzy123

Thread Starter
Joined
May 31, 2020
Messages
2
Hi,

I am using Microsoft office 365 business to send out emails however because I am sending thousands of emails a day through my Itris CRM system which is connected to my office 365 but it seems like they have blocked me from sending any further emails. The bounce back message that I get is this:

Delivery has failed to these recipients or groups:

emails@gmail.com
Your message wasn\'t delivered because the recipient\'s email provider rejected it.

The first 100/200 emails sent fine then I started getting the message above for all the further emails.

I wouldn't be looking to export my contacts or use another database as I have a CRM system so it's just the server side that can integrate with office 365 and allow me to send large amount of emails.

I am a start up company so I need cheap options. Thanks for your help.
 

Couriant

James
Trusted Advisor
Spam Fighter
Joined
Mar 26, 2002
Messages
36,006
It is typical for major email systems like G-Mail to block emails from servers that look like they are spamming them.

Since you have a business account with Microsoft, I assume you have access to their support. Do you have an admin center with your log in to Office365 online?
 

Couriant

James
Trusted Advisor
Spam Fighter
Joined
Mar 26, 2002
Messages
36,006
You should be able to open a support ticket through the Admin Console to check with them on the policies on mass mailing through Outlook. You may need a service like ConstantContact to use for mailing if Microsoft doesn't have a service.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top