Solved Can't switch NVIDIA GTX1650 as primary GPU on FX505DT

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

manteca2

Thread Starter
Joined
Feb 18, 2021
Messages
2
Hi, I've recently purchased a notebook: ASUS TUF Gaming FX505DT. Which has:
AMD Ryzen 5 Mobile 3550H / 128MB ATI AMD Radeon Vega 8 Graphics / 4095MB NVIDIA GeForce GTX 1650 under Win10 version 20H2 (OS Build 19042.804)

The thing is I managed to install NVIDIA drivers, but I can get it to be the default and primary driver in the computer.

I can see both graphic devices appear correctly in DxDiag

Advanced display settings show Vega 8 as display device

If I disable Vega 8 Graphics from Device Manager... everything becomes a little laggy, lose changeresolution possibility, etc. and Advanced display settings doesn't show NVIDIA gpu as display device

NVIDIA Driver is 461.40-notebook-win10-64bit-international-dch-whql.exe
Also downloaded drivers in Asus site and didn't work.

Display Driver Uninstaller's Clean and reset of NVIDIA GPU, reboot and reinstall same NVIDIA driver as above, results the same.
In NVIDIA Control Panel 3D settings --> "Global Settings" Tab --> Prefered graphics processor, "High-Performace NVIDIA processor" is chosen.

I'm really stuck, here an Imgur album in case you want to check anything:
https://imgur.com/a/IS92Mj5
Thanks in advance!
 

manteca2

Thread Starter
Joined
Feb 18, 2021
Messages
2
SOLVED:

The primary GPU will always be Vega 8. Power hungry apps should be manually assigned to use Nvidia GPU. Check this: https://pureinfotech.com/set-gpu-app-windows-10

If you want to, you could enable Turbo mode when needed in Armoury Crate.

its better to use Radeon Vega 8 while idling or office work, less heat and power efficiency.

If you connect your laptop to any external display via the HDMI port, then your GTX should be the display device for the external display. If your games are running by default on the integrated Vega 8 IGPU then you can change it by Right Clicking on the desktop > display settings > graphics settings > then under Graphic performance preference browse your game > select it and then click on options and then select 'High Performance'. This should let you run games on your GTX 1650.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top