Can't turn on wireless network adapter / Acer Aspire 5750

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

wirelessfrust

Thread Starter
Joined
Apr 3, 2015
Messages
2
I have an Acer Aspire 5750. Recently, wireless connection has been spotty on my computer. Phone and other laptops in household work normal using our Wifi.

On my Acer, there is the F3 button that you're supposed to press with the Function button to enable/disable wireless. Unfortunately, that key and other keys on one side of the laptop are broken. So I use a wireless keyboard, that doesn't have that F3 wireless button.

Problem is I can't turn "on" the wireless function on my computer. There is no small switch on the external body of the laptop. Every time I tried to connect to my Wifi, I get a notice that it couldn't connect and to reset my network adapter. The network adapter Intel Centrino Advanced N6205 is enabled when I check the Device Manager. Says it's working normal. Without pressing the F3 button function, I can't find/get to that screen to enable the Wifi.

Any help would be awesome. Thanks so much.
 

flavallee

Trusted Advisor
Joined
May 12, 2002
Messages
81,315
First Name
Frank
Disabling the built-in wireless device and using an external USB wireless adapter may be your best option.

---------------------------------------------------------
 

flavallee

Trusted Advisor
Joined
May 12, 2002
Messages
81,315
First Name
Frank
Thank you. May go buy one if that is only option.
You're welcome, and good luck. (y)

----------------------------------------------------------
 
Joined
Dec 30, 2008
Messages
46
I assume you've tried to get a replacement keyboard?

Next thought is a keyboard emulator program working by mouse pointer.
 
Joined
Jun 27, 2014
Messages
20,185
First Name
Liz
1. Control panel then network and sharing. On the left click change adapter settings.
2. It might say Atheros below Wireless Network Connection; right click on it and choose disable and then when it says disabled choose enable.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top