1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Cant watch videos on Firefox

Discussion in 'Web & Email' started by flyingdutchman, Mar 12, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    Hi there,

    I cant watch any videos from nhl.com or nba.com or nfl.com or tsn.ca on Firefox for some reason. Any ideas? I cant watch youtube though!
     
  2. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    Do you have WMP plugin for Firefox? Type about:plugins in the address bar of Firefox and hit Enter. Check and see if you have these entries for WMP. You can also test the WMP plugin on that site. Youtube uses Flash Player and not WMP. Check these requirements from NBA.com.
     
  3. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    I did everything they said and it still didnt work but in that site they kept talking about wmp 9 or 10...not 11...could that be why?
     
  4. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    I have Firefox 2.0.0.2 and WMP 10 and the videos play for me on the NBA site. Did you check the plugins settings from about:plugins? Match the files listed here to see if any are missing. Then test the WMP on the links under Testing WMP plugin.
    I can't help if you have WMP 11 because I don't use it.
     
  5. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    Hey...so I got 10 and it still doesnt work....it also doesnt work on IE7
     
  6. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    Did you try the WMP test site with Firefox? It the test fails, then the plugin isn't working.
     
  7. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    No..the funny thing is that the test video works...but no other video does!
     
  8. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    If the test passed, then the plugin is working. Try clearing all private data in Firefox including cookies and cache. Start Firefox in safe mode.
    Start> Mozilla Firefox> Mozilla Firefox (Safe Mode).
    This will tell if an extension or theme is effecting the player. If the Adblock extension is installed, the OBJ-TABS setting may hide the WMP plug-in. You will have to disable Obj-Tabs in your Adblock options.
    See if any of this helps.
     
  9. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    Did everything and even tried in safe mode...but didnt work! This is a pain for both you and me because I keep asking you every time but it just isnt working :(
     
  10. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    No problem, just can't make out why your player won't work. Open WMP and click on
    Tools> Options> Network tab and make sure that the 4 boxes on the left under Streaming protocols
    are checked. On File Types tab, that all boxes are checked. If you make any changes, Apply and OK.
    Found this test site from Microsoft Support. Try the different formats and see if any or all work.
     
  11. lexmarks567

    lexmarks567

    Joined:
    Aug 12, 2006
    Messages:
    17,421
    Im wondering do you have flashplayer installed on both web explorers. don't know if that was already covered
     
  12. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    Did everything you said and still no.....I downloaded their first sample file and opened it with wmp and it couldnt open...opened it with winamp and it worked...all the other samples work on quicktime or winamp and not on my wmp..so i cant really tell...also the .asf solution does not work on my wmp (as I said before) and there is no solution to it
     
  13. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    It seems the player doesn't work for the formats. Check this last setting.
    On the Tools menu, click Options> Network tab>In the Proxy Settings section highlight HTTP and click Configure.
    Make sure the proxy setting for HTTP protocols is Use proxy settings of the Web browser.
    Then go to www.cnn.com and click on a video. If a message pops up about a plugin, just click on continue with video and see if the video will play.
     
  14. flyingdutchman

    flyingdutchman Thread Starter

    Joined:
    Mar 12, 2007
    Messages:
    9
    The settings on wmp were already there and when i clicked on a video on cnn.com nothing happens....the video doesnt even play...when i click play nothing happens!
     
  15. Augie65

    Augie65

    Joined:
    Mar 23, 2005
    Messages:
    6,052
    I am lost, the only option I would suggest is to reinstall WMP. You can wait and see if someone has a better idea. Maybe this will help. Installing the Player
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/551190