1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Capture Card not working on my computer

Discussion in 'Hardware' started by TheMcMillionator, Mar 19, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. TheMcMillionator

    TheMcMillionator Thread Starter

    Joined:
    Mar 16, 2012
    Messages:
    2
    My capture card doesn't work on my computer, but it works on my sister's. I am using a Sabrent USB-AVCPT device. My first capture card I ever used was a Mygica EZGrabber2 and it worked fine until it suddenly stopped working. since then I've had the USB-AVCPT and the Sabrent VD-GRBR Capture Box and they both haven't worked. Everytime I try to capture the software says: "capture card could not be opened. make sure it is plugged in correctly and not being used by another program" or "Unable to switch to capture mode. Check to see if drivers are installed correctly. Failed to build a Preview graph." or "No input signal or signal is unclear." The device shows up in device manager and it says its working properly but those messages come up when I try to capture and there is a blank screen. I installed and uninstalled the drivers and software to no avail, but like I said, it works on mu sisters PC perfectly. My PC and my sister's both run Windows 7. My computer is an
    eMachines EL1850G-42w and hers is a Compaq. I updated all the latest drivers and my video card and my capture card still isn't working.:(
     

    Attached Files:

  2. Oddba11

    Oddba11 Jim

    Joined:
    May 12, 2011
    Messages:
    4,648
    Check the device status in Device Manager to ensure it is installed correctly and properly recognized. If the software was installed before the capture card, you may want to uninstall, reboot, and then reinstall the software.
     
  3. TheMcMillionator

    TheMcMillionator Thread Starter

    Joined:
    Mar 16, 2012
    Messages:
    2
    I already did. It says that the device is working properly and I unistalled and reinstalled the software and the same messages still come up.
     
  4. Compiler

    Compiler

    Joined:
    Oct 11, 2006
    Messages:
    5,855
    Sorry, but Sabrent is a generic computer accessories company. They buy stuff, stick their name on it and sell it to the public. I have a Sabrent brand USB external 2.5" Drive enclosure... worst one I ever bought in terms of functioning properly.

    Looking at what is said on Newegg... its pretty bad reviews for their products, not reliable.

    I bought this for $50, http://www.newegg.com/Product/Product.aspx?Item=N82E16815144044 And it works quite good for me. I use it on 3-4 of my computers, the software is pretty good. I have converted my VHS collection to a single 2TB HD and then sent the tapes to a recycle center.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1045801