Cd-rom

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

gnomegnome

Thread Starter
Joined
Nov 4, 2007
Messages
4
Hi - I've got a CD-ROM but it' not showing up in Disk management at all- it's saying 'no media'. If I put any CD in, it doesn't play however the drive is showing in My Computer. Does anyone have any ideas please?

Thanks
 
Joined
May 3, 2006
Messages
22,466
How old is it? They don't last forever....you could try replugging plug and cable. In Device Manager uninstall and then reboot to see if Windows Puts it back correctly. Running cd cleaner through it which would cost more than replacing the drive actually.
 

gnomegnome

Thread Starter
Joined
Nov 4, 2007
Messages
4
Hi - It's about 2 years old, tried the plug, reboot, reintall etc but to no avail:confused:
Not sure what's left to do??
 
Joined
May 3, 2006
Messages
22,466
gnomegnome said:
Hi - It's about 2 years old, tried the plug, reboot, reintall etc but to no avail:confused:
Not sure what's left to do??
Only two things left. replace the cable then replace the drive.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top