1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

cd rom's stopped working under windows XP

Discussion in 'Hardware' started by aigon, Aug 7, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. aigon

    aigon Thread Starter

    Joined:
    Aug 6, 2004
    Messages:
    5
    Hi everyone i have a very ineresting poblem(CRAZY!!) :eek: :mad: :(
    All of my optical drives stopped working under windows 1 dvd-rom 1 dvd-rw
    and 1 cd-rw however they show up in device manager with a yellow ! and when you click on them they show you this:
    Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39):
    Well i tried several times to delete them and to reistall dosn't help they are all loading up but never showing up in "my computer" folder.. (n) In Bios all 3 are showing up + if i put a bootable disk like norton antivirus it will boot from the cd( tried all 3 of my drives all of them will boot from cd). searched for viruses with norton-nothing. SO PLEASE IF ANY ONE HAS ANY IDEA WHAT TO DO OTHER TEH MAKING EVERYTHING FLAT AND REINSTALLING WINDOWS I AM ALL EARS.

    THANK :D S
     
  2. Linkmaster

    Linkmaster

    Joined:
    Aug 11, 2001
    Messages:
    2,872
    Hi aigon, Welcome to TSG !!
    Try this :
    Go to start, run
    2) Type in : regedit then hit OK
    3) Navigate to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\
    {4D36E965-E325-11CE-BFC1-08002BE10318}
    4) Look in right pane and find the Upper Filter and Lower Filter entries.
    5) Right click on each and select Delete.
    6) Close regedit and reboot
    7) That should give you back your CD device.
    NOTE: You may have to go into your BIOS and make sure the CDROM is listed
    also!!

    This usually happens when burning software has been installed and removed or not installed properly!!
     
  3. aigon

    aigon Thread Starter

    Joined:
    Aug 6, 2004
    Messages:
    5
     
  4. aigon

    aigon Thread Starter

    Joined:
    Aug 6, 2004
    Messages:
    5
    thanks TW 56 for such a quck reply i tried what you told me but nothing happend by the way all 3 optical drives are doing the same thing...they are not there... under windows at least. i could not finde the lower filter entries at all there was not even a field saying lower filter however i deleted the upper filter and well nothing happened so far...
     
  5. Linkmaster

    Linkmaster

    Joined:
    Aug 11, 2001
    Messages:
    2,872
    Look in there for each one. Sometimes there are not both upper and lower. See if there is more than one entry for :
    {4D36E965-E325-11CE-BFC1-08002BE10318}
     
  6. Linkmaster

    Linkmaster

    Joined:
    Aug 11, 2001
    Messages:
    2,872
    Be sure to close and reboot when you delete the entries!!
     
  7. aigon

    aigon Thread Starter

    Joined:
    Aug 6, 2004
    Messages:
    5
    ya man there are following enties:

    (default) DVD/cd-ROM drives
    Class cdRom
    EnumPropPages32 MmSys.Cpl,MediaPropPageProvider
    Icon -51
    Installer32 storprop.dll,DvdClassInstaller
    NoInstallClass 1
    Silentinstall 1
    TroubleShooter-0 hcp://help/tshoot/tsdrive.htm

    that is all that is tin the line
    {4D36E965-E325-11CE-BFC1-08002BE10318}


    ok so what do you thimk should be deleted there?
     
  8. Linkmaster

    Linkmaster

    Joined:
    Aug 11, 2001
    Messages:
    2,872
    dont delete anything there.
    Close redit and reboot. Do the drives still have ! on them??
    Do you have EZCD creator installed??
    If so uninstall it!
    Reboot. Look again for the upper and lower filters. Delete them and reboot again.
     
  9. Linkmaster

    Linkmaster

    Joined:
    Aug 11, 2001
    Messages:
    2,872
    Also after you remove the filters, Go back to device manager, right click the drives and remove them . Then reboot.
     
  10. aigon

    aigon Thread Starter

    Joined:
    Aug 6, 2004
    Messages:
    5
    Ya men you are the best i acually installed ezcd-creator and exacactly what i expected happened all the cd's went back online!!!!!!!!! so i deinsalled ezcd-creator again and LALA - the cd's are still there .
    PS When the cd creator was istalling it notified me the upper and lower filter values where incorrect and that it had corrected them... However at the end it all work ..

    Because of people like you man this world is still rotating. Thanks a lot
     
  11. Linkmaster

    Linkmaster

    Joined:
    Aug 11, 2001
    Messages:
    2,872
    You are very welcome.!!
     
  12. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/259048

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice