1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

CDROM install in Win3.1

Discussion in 'Archive: DOS/Other' started by Caper, Jul 29, 1999.

Thread Status:
Not open for further replies.
Advertisement
  1. Caper

    Caper Thread Starter

    Joined:
    Feb 12, 1999
    Messages:
    190
    I've just put a new 40x IDE drive made by BTC into a 486 running ol' 3.1 The drivers loaded fine in DOS, but when I try to access a disc in the D: drive I get:

    Windows (in a gray box)
    This program tried to access your hard disc in a way that is incompatible with the Windows 32-bit disk-access feature (WDCTRL). This may cause yur system to become unstable. Press any key to continue.

    Well, I press the 'any' key, and I got:


    WINFILE.EXE (in a gray box)
    This program has stopped responding to the system.

    I rebooted and tried again, and the system locked up.

    In the AST bios setup, I have the drive configured as a Primary Slave. I just put a new ribbon cable in to do this because there is no Secondary IDE interface. I set the parameters to AUTO as suggested by the setup program for an IDE drive, but upon reboot, none of the parameters have changed (every choice reads zero). No drive parameters came with this drive, not that I expected any.

    Anyone know about setting up a new cdrom in an old box?

     
  2. Caper

    Caper Thread Starter

    Joined:
    Feb 12, 1999
    Messages:
    190
    It had a BTC label on it, but it came in a Digital Research box, so I went to their site and found this:


    In Windows 3.1x I get the message "Windows tried to access the drive in a manner that violates the 32-bit disk access".

    Windows 3.1x will not support an ATAPI CD-ROM in 32-bit mode. You will need to disable 32-bit disk access in the Virtual Memory manager available through the EMM 386 ENHANCED icon in Control Panel.
     
  3. LarryCore

    LarryCore

    Joined:
    Aug 26, 1999
    Messages:
    5,223
    Does that mean you got it working?
     
  4. Caper

    Caper Thread Starter

    Joined:
    Feb 12, 1999
    Messages:
    190
    Yup.

    *slap palm to forehead*
    Why didn't I think of this before!
     
  5. LarryCore

    LarryCore

    Joined:
    Aug 26, 1999
    Messages:
    5,223
    Guess I'll close this one down then.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/39530