Change Browser Language and Interface from Arabic to English

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

JulieG

Thread Starter
Joined
Mar 1, 2013
Messages
2
Hello. I'm an American living in Saudi Arabia. I just bought a Toshiba ultra book. It is very sleek and nice. But everything shows up in Arabic when I use Internet Explorer or Google Chrome. The default language in the control panel is already in English. The location is USA. The desktop is in English. But browsing is all in Arabic. I don't want it to translate...I want all the browsing to be in English. HELP!
 
Joined
Aug 30, 2012
Messages
893
In chrome check Settings > Advanced Settings > Languages (or their Arabic equivalents).
In IE - Internet Options > General > Languages.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top