Changing Drive Letter.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

TimCutler

Thread Starter
Joined
Mar 3, 2000
Messages
225
Hello!
I use an external USB2 IcyBox Hard Disk Drive. It started off as L: but after using a Flash Drive & hooking up my digital camera to the computer its current drive letter is N:It stays as N: even when other USB devices are removed.
I would much prefer this drive to remain at L: in a logical progression after all other drives & partitions I have installed.
How do I get it back to L: & how do I stop it from changing to another drive letter in the future, after using other USB devices?
I am using Windows XP Home SP2. I have one ATA harddrive, which has 4 partitions, (namely C: F: G: H:), & two SCSI hard drives, (D: E:). All hard drives are using NTFS.
Any help with this problem would be appreciated.
Many thanks,
Tim.
 
Joined
Feb 9, 2005
Messages
64
Hey there, to change the drive letter right click on my computer, select manage, click on disk management and then located the hard drive that you wish to change the letter of and then right click on it and select change drive letters and paths. Then just select the letter you wish. A warning message will appear that says "Changing the dirve letter of a volume might cause programs to no longer run. Are you sure you want to change this drive letter?". All it is saying that if you installed any programs that run from that drive then they will no longer work once you change the drive letter so be careful. You are safe if it is just a hard drive where you store things. As for preventing it to change to another letter I have no idea. Someone else might though. I hope this helps.
 

TimCutler

Thread Starter
Joined
Mar 3, 2000
Messages
225
Many thanks, Zupadupa,
It is easy to change the drive latter, but I am hoping that it will stay as I set it, after I have used other USB devices... we'll see!
Best wishes & thanks again.
Tim.
 

911

Joined
Mar 25, 2003
Messages
546
I don't understand why, but Windows won't let you assign a drive letter to just anything. I had the same problem, and eventually discovered that you have to lie a little to fix it.

Click Start > Settings > Control Panel and select SYSTEM.
Click the Device Manager tab.
Ensure that there is a dot in 'View devices by type'.
Click the + next to the icon for the device type (Probably Mass Storage)
Right click the appropriate device that drops down and select 'Properties'
Select the Settings Tab on the next menu
Check the box marked 'Removable'
Now you can assign a drive letter that will be permanent in the box below. Choose the lowest letter available. I don't remember if you need to restart and go back there before you can assign a letter, but the important thing is so get the device reclassified. It will appear in the Device manager among the disk drives afterwards.
---911
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top