Changing IRQs... ?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

That_one_guy

Thread Starter
Joined
Dec 8, 2001
Messages
18
I seem to keep having memory errors with winamp and windows media player (sound and video). It's those errors with the hex numbers... memory locations or something I believe.

I don't know if it has anything to do with the IRQ settings, but I noticed that both my sound (onboard audio from the motherboard) and my graphics card (GE Force 2 MX400) share the same IRQ numbers, number 11. It lists as...

(PCI) 11 CMI8738/C3DX PCI Audio Device
(PCI) 11 NVIDIA GeForce2 MX/MX 400

Also... all the other numbers have a different device allocated to them.. from 0 to 9, then it skips 10, and goes to 11 for these two. Is that ok? Any help and clearing up appreciated, thanks!
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
43,117
That is a function of ACPI [Automatic Configuration Power Interface] it is doing what it is supposed to do. On rare occasions ACPI can cause problems. ACPI can be disabled and separate irq’s assigned to devices. I do not think that ACPI causes all of the problems that some people believe it to cause.
Prior to disabling ACPI, check for driver updates for your devices, check what programs are running in the background, [check services also] try closing anything that is not absolutely necessary. After doing these things see if you still get the memory errors. Check the event viewer for errors, this can give you some information as to what may be causing your problems.
ACPI can be disabled from within win2k and you should not have to reinstall your operating system. Here are the instructions for doing so. Again let me reiterate that you should check all other possibilities prior to disabling ACPI.

Under Windows 2000 you can disable ACPI from within Windows as follows:

Go to Device Manager and select Computer -> Properties of ACPI PC
Click the driver Tab and choose Update Driver
When the wizard gets to the "What do you want the wizard to do?" page select "Display a list of the known drivers..."
Then "Show all hardware of this device class"
Then select "Standard PC"
Reboot the machine
When Windows 2000 restarts it'll redetect most of the hardware in your machine again and reassign IRQ's to them, turning off ACPI.
You should have device drivers for your hardware handy since you may have to reinstall them.
Note: If you installed Windows with ACPI enabled in the BIOS, and then you disable ACPI using the BIOS, you may need to do a fresh install of Windows!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top