1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Chkdsk says it "cannot continue in read-only mode" at command prompt

Discussion in 'Hardware' started by diablo75, Jan 6, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. diablo75

    diablo75 Thread Starter

    Joined:
    Sep 7, 2006
    Messages:
    617
    I've been having a lot of problems with a certain hard drive lately. So I went to dos to run chkdsk and got the following:

    D:\>chkdsk
    The type of the file system is NTFS.
    Volume label is Big one.

    WARNING! F parameter not specified.
    Running CHKDSK in read-only mode.

    CHKDSK is verifying files (stage 1 of 3)...
    Deleting corrupt attribute record (128, "")
    from file record segment 4197.
    Deleting corrupt attribute record (128, "")
    from file record segment 4217.
    Deleting corrupt attribute record (128, "")
    from file record segment 4219.
    Deleting corrupt attribute record (128, "")
    from file record segment 4222.
    Deleting corrupt attribute record (128, "")
    from file record segment 5038.
    Deleting corrupt attribute record (128, "")
    from file record segment 5050.
    File verification completed.

    Errors found. CHKDSK cannot continue in read-only mode.
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    That's normal. Chkdsk can't fix anything while XP is running. Run: chkdsk /f and choose "Y" to run it on next reboot.
     
  3. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Is the D: drive where XP is installed?
     
  4. diablo75

    diablo75 Thread Starter

    Joined:
    Sep 7, 2006
    Messages:
    617
    No, D is not where XP is installed.

    I'll try the chkdsk /f option

    Edit: I think that did the trick! Thanks!
     
  5. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    So it may even run without rebooting. If there is just data there you can also try including the /x switch to force a dismount. This works great.
     
  6. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    It is irrelevant where XP is installed. To run chkdsk on your system partition, simply type:

    chkdsk /f

    and agree to run it on startup.
    To run chkdsk at boot on another partition that gives you the above message because it is in use, type the same command with the drive letter specified:

    chkdsk D: /f

    The option exists to "unlock" the drive and terminate all handles to it so that chkdsk can be run without a reboot. But that is riskier and unnecessary since you don't ordinarily know what threads are running and the consequences of terminating them.

    Mr. Cerelli is posting in this thread contrary to the site owner's instructions and can be ignored.
     
  7. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Yikes......

    To help clear this up, for example, since in this specific case XP is not installed on the drive in question, you could run chkdsk on the D: drive without rebooting. Just want to clear that up.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/532939