Christmas fail: HP a6112n won't turn on!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

gt9084

Thread Starter
Joined
May 7, 2007
Messages
19
My girlfriend bought me a brand new NVIDIA GEFORCE GTS 450 graphics card for my HP a6112n DESKTOP for Christmas last night; we watched numerous installation videos and it seemed pretty easy enough. After closing the case, confident that I'd be enjoying better graphics in a matter of minutes, we found that my desktop would not even turn on after pressing the power switch!!! :eek:

Initially the green power supply light behind the tower was blinking, and thought it may have been that. Now when I plug in the power cord, it doesn't even do that. After looking through tons of trouble shooting articles, I've attempted and tried all of the following:

1. toggled the red switch underneath the power light supply back and forth.
2. pressed and held the power switch for 5-10 secs.
3. removed and placed back the lithium cell battery inside the tower.
4. checked cords that may have been unplugged in the process.
5. removed and placed back RAM.

I've given up installing the graphics card for now, and just want my desktop back to its original condition. I'm afraid I fried the motherboard or did some irreversible. I'm really just hoping its a power supply issue.

If you have any input or suggestions, PLEASE let me know. Thanks in advance!
 
Joined
Aug 12, 2003
Messages
5,602
your hp probably has a 300w power supply
your gts 450 video card prob' needs a 400w+ power supply
don't know this for a fact........but look into it!!!
 

Noyb

Jay
Trusted Advisor
Spam Fighter
Joined
May 25, 2005
Messages
21,134
A shop should be able to test the supply quickly.
Here's a HP 460W power supply.
I've upgraded a couple of HP's with this supply .. Primary because the wiring is for HP's
Sometimes .. It can be a problem stuffing the wiring from the universals in the HP case.
 

gt9084

Thread Starter
Joined
May 7, 2007
Messages
19
@ replay: I looked up the watt requirements, and you were absolutely right! Definitely surpassed my HP's power supply. Have I damaged my motherboard or any other essential parts to the tower to prevent me from recovering and installing a new power source that could handle my new graphics card? QQ

@ Noyb: I will hopefully resort to this replacement if my tower is salvageable. What "shop" were you referring to? Would a "Staples" or "Best Buy" be able to test my power supply, and install the 460W supply you described? Or is there a more specialized (and cheaper, of course) place I can go to for all this?

Thank you guys for the replies, and on a holiday at that! I really do appreciate all this.
 

Noyb

Jay
Trusted Advisor
Spam Fighter
Joined
May 25, 2005
Messages
21,134
I was thinking a local computer repair shop .. Staples or BBuy should be able install a new supply.
There's other good supplies .. I just trusted HP's quality and noise level ..
and knew the wiring wasn't excessive.

I tried to stuff the long wiring from a universal supply in a small HP case once ..
It wasn't pretty to look at :D
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
82,264
Have you removed that GTS 450 video card and then tried to start the computer? I don't see anything in your comments as to whether it's been removed or is still in its slot and is still connected to the monitor.

---------------------------------------------------------------
 

gt9084

Thread Starter
Joined
May 7, 2007
Messages
19
@ noyb: I think I'll stick to the same manufacturer and lean towards your recommendation. I am not going anywhere near installing anything by myself anymore after this mishap, so local computer repair shop it is. haha

@ flavallee: Ah yes, I neglected to include the fact that I've taken the graphics card out and install the tower the way it was prior - the initial reaction was a blinking power supply light, and unable to turn on. I tried it multiple times, and now the green light won't even turn on. I'm thinking I burnt out the power supply completely? And I'm definitely hoping I havent done anything too serious like fry the motherboard or something important in the process. What's your opinion? Thank you for the response!
 

Noyb

Jay
Trusted Advisor
Spam Fighter
Joined
May 25, 2005
Messages
21,134
If it worked for awhile .. I really doubt that you fried the MOBO.
The green lite not showing would indicate a bad PSU ..

I have taken a PSU apart .. And I think I saw a fuse in them .. But it's probably not serviceable by you.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top