Chrome & firefox won't load several websites

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Oren21

Thread Starter
Joined
Jan 10, 2013
Messages
1
I've been having this problem for the last few days.
I'm unable to load several websites that I often visited. Like yahoo and facebook in particular. It takes sooo long to load and it doesn't load properly. Images and words are distorted. Anything to do with yahoo, like yahoo answers, omg!yahoo, opening an article, etc. won't load at all. Error 324 will come up.

I have 3 laptops and they are all connected to the same wifi. Only 1 works perfectly. The other two, a toshiba and a mac, are having this problem.

I think it's the connection problem... Because when I used my iPhone as a hotspot, everything works fine. I have no idea why the other laptop is working just fine.

I use google chrome as my main browser. At first I thought the problem is with chrome, so I installed firefox as well, but no luck. I tried accessing the webs in safe mode, cleared cookies, cache and history, clear DNS cache, none worked. I did all this on my windows 7 laptop.

Any suggestion on how to fix it?
I'm not very tech-savvy, so please be patient with me when you're explaining it :D
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top