1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Cisco and vlans

Discussion in 'Networking' started by xpellex, Oct 26, 2018.

Thread Status:
Not open for further replies.
  1. xpellex

    xpellex Thread Starter

    Joined:
    Oct 23, 2018
    Messages:
    1
    Hello forum. Thank you all in advance.
    I'm in the process of building a home lab for microsoft and cisco studies and am working with the following devices:
    Home netgear router (connected to ISP)
    Cisco 2800 series router
    Cisco 2960 layer 2 switch
    PC1 (win 10)
    PC2 (win 10)
    Issue:
    PC1 (on vlan 10) and PC2 (on vlan 20) are both able to access the internet, but there is no communication between the vlans (im unable to ping PC1 from PC2 or vica verse) Nor are hosts on VLAN 20 getting DHCP address. If i statically address hosts on vlan 20, they can get on internet, and each host on each vlan can also ping the gateway of the other vlan, ie, 192.168.3.10 can ping 192.168.2.1, but NOT 192.128.2.10 etc. I'm setting up a home lab and any suggestions would be welcome! Router and Switch configuration below:::::: I'd be happy to provide any further information needed. Thanks!!
    I have set up router on a stick and my configuration looks like this:

    ip dhcp pool testuser1
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.1
    dns-server 8.8.8.8

    ip dhcp pool testuser2
    network 192.168.3.0 255.255.255.0
    default-router 192.168.3.1
    dns-server 8.8.8.8

    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    !
    !
    !
    license udi pid CISCO2811 sn FHK1110F1ZZ
    !
    redundancy
    !

    interface FastEthernet0/0
    ip address dhcp
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    description test vlan
    encapsulation dot1Q 10
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    interface FastEthernet0/1.2
    description test2 vlan
    encapsulation dot1Q 20
    ip address 192.168.3.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    !
    interface Serial0/2/0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial0/3/0
    no ip address
    shutdown
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.0.1
    !
    access-list 1 permit any
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    transport input all
    !
    scheduler allocate 20000 1000
    end
    My switch configuration looks like this:

    Current configuration : 3394 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    !
    no aaa new-model
    system mtu routing 1500
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    !
    !
    interface FastEthernet0/1
    description trunk to router
    switchport mode trunk
    spanning-tree portfast trunk
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/22
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/23
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/24
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/25
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/26
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/27
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/28
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/29
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/30
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/31
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/32
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/33
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/34
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/35
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/36
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/37
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet0/38
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet0/39
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet0/40
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet0/41
    !
    interface FastEthernet0/42
    !
    interface FastEthernet0/43
    !
    interface FastEthernet0/44
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/45
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/46
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/47
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/48
    switchport access vlan 20
    switchport mode access
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
    description test2 vlan
    ip address 192.168.2.2 255.255.255.0
    !
    interface Vlan2
    description test3 vlan
    ip address 192.168.3.2 255.255.255.0
    !
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Cisco vlans
  1. nitehawk645
    Replies:
    3
    Views:
    410
  2. morum
    Replies:
    6
    Views:
    615
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1218358

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice