1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Clock on Win7 Laptop is 5 Hours Ahead

Discussion in 'Windows 7' started by SteveBernstein, Feb 11, 2017.

Thread Status:
Not open for further replies.
Advertisement
  1. SteveBernstein

    SteveBernstein Thread Starter

    Joined:
    Oct 1, 2016
    Messages:
    47
    I'm not sure if I should be asking this question in the Linux/Unix forum or on this forum. I have a Win7 laptop with Windows 7 and Ubuntu installed side by side. The clock on my Windows 7 partition is 5 hours ahead, but the clock on my Ubuntu partition is correct. Could my Ubuntu partition be causing this issue? If it were really a (CMOS) battery issue, wouldn't the clock on my Ubuntu partition also be off?
     
  2. Sponsor

  3. etaf

    etaf Wayne Moderator

    Joined:
    Oct 2, 2003
    Messages:
    63,307
    have you changed the time on the w7 to the correct time ?
    if so does it change again
    have you also change the timezone and synced to an internet service

    click on the date and time
    change time
    change time zone
    goto the internet tab
    and make sure its set to sync
     
  4. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,487
    After you make sure the time and the settings (time zone, etc,) are correct in Windows you probably have to fiddle with the settings in Ubuntu.

    When I had that problem between Windows and a Linux distribution (don't remember if Puppy or Ubuntu) I had to run the command /etc/default/rcS UTC=no to tell the Linux to use local time (as Windows does) instead of UTC time.

    Not saying that will be the exact solution for you, but it should put you on the right path.
     
  5. plodr

    plodr Liz

    Joined:
    Jun 27, 2014
    Messages:
    11,874
  6. SteveBernstein

    SteveBernstein Thread Starter

    Joined:
    Oct 1, 2016
    Messages:
    47
    @etaf I did everything you said. I checked to see if the correct time zone was set, and I also checked whether the time was syncing with a server. The things you said work for awhile, until I decide to boot into Ubuntu again.
    @TerryNet Can you run down the list of commands I would have to run? I've come a long way with the command line, but I'm not yet comfortable with editing text files.
    @plodr What should I do then to fix this issue?
     
  7. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,487
    This Clock time is off on dual boot tells how to change Windows to use UTC and how to change Ubuntu to use local time. Do whichever you prefer, or search for other instructions. I found this link with a web search for "Ubuntu UTC" (w/o the quotes).
     
  8. plodr

    plodr Liz

    Joined:
    Jun 27, 2014
    Messages:
    11,874
    Me, I do not dual boot. When I run a live linux USB and it shows the wrong time, I leave as is. (Not all distros use UTC so the clock is not always wrong).

    When I boot into windows, I simply reset to my time zone.
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1185220