Cocopa CD/DVD external drive not working

oxfordemma78

Thread Starter
Joined
Sep 14, 2017
Messages
4
Hi my husband has sent me some CDs he needs me to look through here in the U.K. I brought a external CD/DVD drive for my laptop that has windows 10 on it. It finds it on the laptop then disappears as soon as I put a CD in. Or a question mark appears on it. Sometimes it will open up and then nothing will play the media on the disc I’ve tried windows media player and VLC media player. I’ve tried uninstalling it and reinstalling it. Changing the region on it. Even resetting my laptop and nothing helps. I can’t access the data on the discs. At the moment is it showing up on my laptop as DVD Rom drive F. As soon as I try and put a CD in it will power up and disappear. Or if it gets as far as locating the contents nothing will play them :( has anyone for any ideas that might help? Thank you.
 

Noyb

Jay
Trusted Advisor
Spam Fighter
Joined
May 25, 2005
Messages
21,228
Can you Browse (explore) the CD/DVD and read the file types on the CD/DVD ??
What are they ????
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top