1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Compaq CQ60 boot Problem

Discussion in 'Hardware' started by Peter2301, Apr 22, 2014.

Thread Status:
Not open for further replies.
Advertisement
  1. Peter2301

    Peter2301 Thread Starter

    Joined:
    Feb 15, 2014
    Messages:
    87
    Laptop powers on and all power lights come on accordingly. Fan powers on OK. But no BIOS or anything else comes on screen and HDD does not power up, HDD light does not come on either. I have taken out HDD, tested it and reseated it, it appears to be working fine. I have re seated the RAM. I have taken the battery out and discharged the power holding down the power button for 60 seconds. Nothing has worked. Any ideas?
     
  2. SM4SH

    SM4SH

    Joined:
    Aug 24, 2013
    Messages:
    198
    if the computer powers up, but the HDD does not spin (and you are sure it is correctly plugged in). you should try to put the drive into another machine (if you still can) and copy your data off. This sounds like your HDD might be failing plug it into another machine and copy your data off (sometimes a failing drive can be read in a different computer as a secondary drive). if you want to check the drive you can try a program like crystal disk info. Keep in mind, if these programs say the drive is bad then it is bad, but if they say its good, it might still be bad.
     
  3. Peter2301

    Peter2301 Thread Starter

    Joined:
    Feb 15, 2014
    Messages:
    87
    Already did that, it appears to be working fine. Ran diagnostic software and no faults found. I can access all the data on the drive. What puzzles me is thre is no BIOS appearing at all. If I take the drive out the laptop should still boot until the BIOS attempts to access it then give me warning there is no boot disk, this doesnt happen
     
  4. SM4SH

    SM4SH

    Joined:
    Aug 24, 2013
    Messages:
    198
    Your right. I missed where you said that. Then it seems like it might be an issue with the motherboard. Is the machine by any chance still under warranty?
     
  5. Peter2301

    Peter2301 Thread Starter

    Joined:
    Feb 15, 2014
    Messages:
    87
    No it isnt under warranty, I thought it was motherboard just wanted to make sure I hadnt missed anything thank you
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1124611

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice