Computer loading BIOS but giving red screen or no signal

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Filippos

Thread Starter
Joined
Jul 19, 2018
Messages
1
Hi dear fellows,

I just connected my brand new PC with the monitor, yet I fail to get windows on the screen.
The computer turns on, bios is accessible and visible on the screen, yet right after windows screen, the monitor goes bananas - red screens, green screens, blank and all over again. It appears it is trying different resolutions for some reason.
Any clue what is happening??

The PC has windows 10, six i5 cores and gtx 1050Ti, if that would be of help.

Thanks a bunch!
Filippos
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
43,438
OK, first of all you need to post your exact system specs; ie exact motherboard, exact processor, exact video card [if installed] exact pw supply, etc, etc. Do not post "500W pw supply" Post the exact brand and model# Do that for ALL of your parts.

If you purchased this as a built system, have you contacted the seller? If you start messing with it, you may void any warranty.
If you built the system, then we can proceed to attempt some basic troubleshooting.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top