1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

computer not recognizing usb ports

Discussion in 'Hardware' started by beandox, May 24, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. beandox

    beandox Thread Starter

    Joined:
    May 23, 2007
    Messages:
    42
    hi

    i recently updated my computer and installed win xp. i have 4 usb ports total on my computer, 2 in the back and 2 on the side. the 2 usb ports on the back of the pc work fine however my computer isn't recognizing and reading the 2 on the side. they used to work fine but now they don't.

    any suggestions?

    thanks greg
     
  2. racock

    racock

    Joined:
    May 22, 2007
    Messages:
    72
    Have you checked the internal cabling to it. Could just have dropped off / got snagged round something while doing an upgrade. Alternatively, check in your Device list, to see if there's anything shown up as baing unknown or disabled.

    Rich.
     
  3. TannerStauss

    TannerStauss

    Joined:
    Apr 21, 2007
    Messages:
    30
    go to My Computer, Right Click on it and Select Manage, go to Device Manager, Scroll down, if there are any hardware with yellow question marks you must update the drivers. If that is not the case, it must be a wiring issue. If its not that, I dont know.
     
  4. beandox

    beandox Thread Starter

    Joined:
    May 23, 2007
    Messages:
    42
    the problem seems to be almost fixed. the thing now is no matter what i plug into the very front usb port on the side of the computer comes up as "unknown device". however the device will work with the other ports.

    for example i had my printer plugged into the back port, and it worked fine. i tried the front port on the side...unkown device. even if i try to install the drivers from the printer disk, i get unkown device. same thing when i tried to plug my ipod in the front jack, it worked on all 3 other usb ports, just not that one.

    thanks for the help

    greg
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/576751