Computer won't get past black screen after showing PC brand logo.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Vertigo9907

Thread Starter
Joined
Nov 11, 2011
Messages
2
I'm having some serious troubles with my main PC, my gaming PC, and it's really messing things up for me.

I was just parusing around like usual on my computer, it runs Windows 7, and I allowed it to download the usual updates and restart itself. When it shut down and began restarting, I notice that it loads up the logo, briefly flashes what I think is called a Bios Post page, and then goes to a page that is nothing but a blinking "__" sign. It does nothing here, won't continue, and I can't enter or do anything. It just endlessly blinks, before disappearing and the computer screen shows nothing but black.

Can I get some help here? I'd really appreciate it. .___.
 
Joined
Sep 21, 2009
Messages
1,312
Have you tried to start in "Safe Mode" to see what happens? (Pressing F8 repeatedly immediately upon booting).
 

Vertigo9907

Thread Starter
Joined
Nov 11, 2011
Messages
2
It won't get that far. I tried, and it just continues and goes to the endless screen with the blinking "__"
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top