Computer wont power on

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Warning|

Thread Starter
Joined
Sep 27, 2007
Messages
23
i just finished installing a bolt down heatsink because i couldnt deal with the pushpin one.

i plug in the power supply to the motherboard. i get LED on the mother board but when i press the power button the LED on the power supply blinks once and thats all. the LED on mother board stays on but no juice.

if i continue to press the power button the LED on the PSU does not light up again until i unplug and plug back in.

any ideas?:confused:
 
Joined
Sep 29, 2008
Messages
513
Unless the new fan draws significantly more current and overruns the power supply, I'd say you might have done something to the CPU (like unseat it) when you put the new fan on. It's Power Supply or CPU most likely.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top