Computers have drastically different download speeds on the same network

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

NyanOctoCat

Thread Starter
Joined
Jul 22, 2017
Messages
1
I have four devices, Windows 8.1 laptop (mine), Windows 10 laptop, iPhone SE, Android phone, connected to the same network and the Windows 8.1. laptop has a significantly slower download speed (~15 Mbps) than any other device (~100 Mbps for the phones, ~120 Mbps for the Windows 10 laptop). Moreover, I also get very different results depending on where I measure my speed while the other devices get almost identical numbers on all websites I’ve checked. Specifically: beta.speedtest.net shows me 170+ Mbps, fast.com shows 70 Mbps, speedof.me (HTML5 based, arguably the most accurate) shows only 15 Mbps. I get the results regardless of whether I am connected through WiFi or Ethernet (tested with multiple cables).

Here’s what I’ve tried to do so far to troubleshoot the problem:
  • Making sure that my network drivers are up to date.
  • Booting in safemode with network. Same results.
  • Checking for bandwidth hoggers. I ran netstat -o and checked each PID to make sure it wasn’t anything suspicious. All PIDs were either Chrome or the antivirus. I tried disabling and eventually uninstalling the latter.
  • In Task Manager’s Resource Monitor I checked the processes under Network. All of them are either chrome, svchost, or System, and the numbers look very similar to those I am seeing on the Windows 10 laptop. I also tried running several speed tests and monitoring the number change, and the dynamic was the same to what I observed on the Windows 10 laptop.
  • Scanning for malware. Before uninstalling the old antivirus that I had, I ran the scan but didn’t find anything. I then downloaded Malwarebytes but it didn’t find anything either. I am currently in the process of picking a new antivirus. Once I pick one, I will do a scan with it too, but it doesn’t look like it’s malware that it is causing the problem.
  • Finally, I tried resetting my network configuration by running netsh winsock reset catalog, netsh int ipv4 reset reset.log, netsh int ipv6 reset reset.log. No effect.
I am at a loss what other software solutions I can try and I am worried that there is something wrong with the NIC or adapter (which can be a pain to change in a laptop). For comparison, my laptop has Realtek PCIe GBE Family Controller and Intel(R) Dual Band Wireless-AC 7260 and the Windows 10 laptop has This Killer Ethernet Controller and Intel(R) Dual Band Wireless-AC 3160.

If you have any suggestions or guesses on what might be going on, please comment. Any input would be greatly appreciated!

EDIT :I discovered that that this is not a hardware issue as I just made a bootable USB with Kali (Unix-based OS) and running it all speed tests showed 100 Mbps! This means that whatever is happening, it is a software issue and not a problem with the NIC/modem/any laptop piece.

SOLVED!!!
Found the problem! The issue was caused by having the Windows Auto-Tuning feature set as disabled instead of normal. What I did to fix it:
  • In command line (as administrator), run netsh interface tcp show global to see if the feature is disabled
  • Run netsh interface tcp set global autotuninglevel=normal to set it to normal
Voilà!
 
Last edited:
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top