Conflicting usb ports

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

yakuza389

Thread Starter
Joined
Oct 9, 2005
Messages
9
Hope someone could help me with this one...I have a 4 year old HP comp running on XP home. Everytime i plug in my camera into usb in the front, it doesn't recognise the usb port in the back or viseversa. It used to work fine until recently....The other port i have my printer plug into it......any suggestions?....john
 

cybertech

Retired Moderator
Joined
Apr 16, 2002
Messages
72,115
Hi yakuza389, Welcome to TSG!!

I'm not sure I understand your post. Is the camera working on any usb port?
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,522
Create a file with NOTEPAD containing the following lines and save it as FIX.REG
-------------------------- cut here --------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
-------------------------- cut here --------------------------------

Double click on FIX.REG and say yes to the Merge Into Registry question.

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives that you know are not present.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.
 

yakuza389

Thread Starter
Joined
Oct 9, 2005
Messages
9
CyberTech,

Yes cam is working, the other usb is not recognized by comp. Printer is connected on the other usb port. When Cam is hooked up on Comp....there's no icon in My Computer for the other usb....
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top