Connection keeps dropping. Seems to be pc issue.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Darkchisl

Thread Starter
Joined
Dec 24, 2014
Messages
12
I have been having issues with my connection just cutting off. happens during gaming and i loose connection tio the server and when just browsing the net.
Connection icon shows total disconnection then comes back on after a few seconds.

It is not the windows 10 power saving as i have shut that down.
Isp has run checks and its not them or router.

My only guess is it could be my network card or some other issue.
Not noticing any issues with other devices on my home network either so seems isolated to my pc.

Can someone help me to diagnose what could be causing the issue.
I have tried looking for diagnostic software but struggling to find anything suitable.
 
Joined
May 1, 2017
Messages
235
First Name
Naresh k
Do you have any problem with connection drop when you have the ethernet connected to a different computer? are there any latest drivers for the desktop lan card?
 

Darkchisl

Thread Starter
Joined
Dec 24, 2014
Messages
12
I already checked the drivers.
However I have noticed that there are 2 other devices that were hidden devices, please see pic.

Do I need these? or are they safe to remove?
wan.PNG
 

TechGuy

Administrator
Joined
Feb 12, 1999
Messages
14,498
First Name
Mike
Those are standard drivers and probably not related to this issue. Does the network icon show that the cable is disconnected when this happens? I'd try to swap out the cable and use a different port on the router to rule them out. That seems more likely to me than a software/driver issue.
 

Darkchisl

Thread Starter
Joined
Dec 24, 2014
Messages
12
It does show the cable disconnect icon. Tried new port and new cables from router to pc and router to socket also....same issue
 

TechGuy

Administrator
Joined
Feb 12, 1999
Messages
14,498
First Name
Mike
My money would be on bad NIC in that case. Any chance you or someone you know has a spare one lying around for testing? Fortunately, they're pretty cheap these days even if you have to buy one.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top