Constant Lag on mouse inputs, From Browsing the web to Games

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

AztecAlpha

Thread Starter
Joined
Feb 24, 2018
Messages
2
Ever since I upgraded my PC (about 4 Months ago) I have been experiencing a constant Lag or Jumping of my mouse. It often occurs when there is some form of tab opening, loading, or strain on computer. This may seem like an obvious your computer is slow, but its not. It is more than capable of running a you tube video.

I would describe the lag as: all cursor movement is delayed, my mouse freezes, if i"m clicking its clicking, if I move it stays still. Then after about 5-15 seconds all movement and inputs on the mouse are completed at once causing spastic movement of my cursor.
I have tried very little, mainly because I know its not my mouse, as it happens on both mice i have. It seems that it very well could a hardware issue, at the same time a software issue, as when I switched my motherboard I had gotten a different brand. I have no idea as for all I know it could be my Power supply.

-GeForce GTX 1060 6 GB
-AMD Ryzen 3 1300X Quad-Core Processor
-8 GB Ram (HyperX)
-GIGABYTE GA-A320MA-M.2 AMD Ryzen AM4 Motherboard
-(I think) Westsern Digital Blue 1 tb
-Running Windows 10

A video of it happening: https://www.youtube.com/watch?v=-sGKtvuPGLY&feature=youtu.be

There are More examples in the description (time stamps under the title)

I want to disclose that this is not gaming support, I used a game in the video as described earlier, it occurs when my pc is under stress, at varying levels (like loading a video at 144p to playing videogames) and found that the fastest way to produce results was to play the game.
 

dvk01

Derek
Retired Moderator Retired Malware Specialist
Joined
Dec 14, 2002
Messages
56,452
I have frequently found this to be a graphics card issue. Updating graphics drivers can sometimes help
 

AztecAlpha

Thread Starter
Joined
Feb 24, 2018
Messages
2
I have frequently found this to be a graphics card issue. Updating graphics drivers can sometimes help
I have updated my Driver. I have just stress tested it again and The issue still prevails. Any other ideas?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top