Cooler Master Warranty Process

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

crcook84

Thread Starter
Joined
Aug 12, 2010
Messages
467
I recently had the joy of having a power supply from Cooler Master fail on me. (No comments about the quality of their products, please.) Because it failed on me around 6 months after I bought it, I decided to check out the warranty. They have a basic 2 year warranty of the majority of their PSs with a special 5 year warranty on a particular line of PSs. As such, I decided to make good on their warranty. I emailed them and they pointed me to a link to register. I completed the registration process (I thought) but was having some difficulty registering the product.

I looked around elsewhere on their website and found a replacement parts request section. I tried filling out the form and then emailed them to let them know what I had done. Apparently, I had to register at a particular area on their website because I would need an RMA number. At the time, I didn't know what it was because I haven't had to ship anything out over the past year or two.

I was, finally, able to register my product after filling out the form a couple of times. I don't know if it was because of their website or the finalization process just takes a while. One thing I knew I could have to figure out how to do it send the invoice to verify the purchase. Fortunately, they were okay with me uploading a JPEG of the invoice. It didn't take long to verify my purchase and, in so doing, verify the warranty. They sent me an address and an RMA number to get the product shipped.

After a day or two, I logged back into the website to see how the process was going. I started clicking some of the links when I came across "Instructions" on how to ship the item. It said that I was required to send the item with the RMA number and a copy of the invoice. Nowhere in their email to me did they say that I would need to add a copy of the invoice to my package. Besides that, if I was already verified, why would I need to continue sending that kind of information.

I emailed then inquiring about what was going on with the process and they informed me that, because I uploaded the invoice, it was no longer required and that all I would need to send the package is the address and the RMA number. I can definitely say that they're very helpful with making sure their customers understand what is going on. However, it would be helpful if they update their instructions.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top