CPU light on fans on but won`t boot up ?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Midnightmodz

Thread Starter
Joined
Sep 14, 2018
Messages
1
Hi My freind gave me his old Gaming PC as he bought a new one the fans come on and stay on so do all the leds on the front panel however it wont do anything wont boot just shows black screen is there a way to fix this we tried a new PSU but did not make no difference.
Many thanks
 
Joined
Mar 29, 2018
Messages
74
First Name
Aaron
That could be anything....motherboard, cpu, ram, PSU, GPU, etc. You have to start the diagnosis process. Unplug EVERYTHING from the board except the PSU (and GPU if you don't have onboard video), and see what it does. You can leave the power switch button hooked up but I recommend jumping the pins.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top