Cygwin OpenSSH doesn't listen on actual IP, only on 127.0.0.1

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

JavaBird

Thread Starter
Joined
Jun 10, 2009
Messages
2
Hi folks,

today I setup Cygwin and OpenSSH on my rented server. I following the usual direction and everything seemed to be fine.

I tested locally using ssh localhost und voila - connection, login, everything fine.

Then I tried to login from my laptop and got no connection. I checked the firewall - and it was off. Both the server provider's firewall and the local windows firewall were off (I turned them on afterwards, however).

Ok, I thought, let's connect locally, so I tried ssh <hostname> and ssh <server-ip> (On the server itself!). Could not connect.

I tried a lot of combinations, changed the port, used ListenAddress to explicitly bind to the local ip, looked at hosts.allow and hosts.deny etc. Actually one can see slight differences with netstat -a, but the effect remains the same: Using localhost and 127.0.0.1 I can connect, but not using the IP.

Server OS is Windows Web Server 2008.

Any ideas?

Thanks for hints or any idea how I can debug this. SSH debug mode shows no output, so it really seems no connection gets established.

Regards,

JavaBird
 
Joined
Jun 10, 2009
Messages
228
Does the software have an option to change what ports it is listening on? Is their a check mark that you could of over looked that would cause it it only be listening on the loop back address?
 
Joined
Sep 12, 2003
Messages
20,583
Hi Javabird,

Welcome to TSG!

Do you have a hardware router? Do you have a dynamic or a static IP address? Do you have the web server hooked up in a DMZ behind a firewall? Is your laptop and web server hooked up on the same subnet both behind your hardware firewall?

If you have a hardware router that is not on 24/7, and your system boots up using DHCP, then you should get a new IP address on every new boot, which is how your router is identified to the Internet. You computer is assigned an internal IP address, something like 192.168.1.2, while your router is most likely 192.168.1.1. Your computer's name is also known as localhost, i.e. 127.0.0.1. If your system is up 24/7 and the router is assigned a static IP address by your ISP, then it stays the same between reboots.

Issue a "route -n" command to see what you get, i.e. maybe an internal IP address for the server:
$ route -n

Browser software is easy to setup different ports for listening in the configuration network part of the preferences of the Browser.

-- Tom
 

JavaBird

Thread Starter
Joined
Jun 10, 2009
Messages
2
Hi Lotuseclat79,

this is a server hosted by some german service provider. It has a fixed IP and the IP is in the DNS under a number of domain names and the actual hostname (you can do a NSLOOKUP from anywhere). So there is no DHCP in the game.

My laptop - which I'm using to access the server - is in the local network behind a router with dynamic IP.

I also changed the port to 10022 but that doesn't change anything.

As there might other problem between the laptop and the server I fell back to testing on the server only - and even there I cannot connect using the IP (or the hostname) of the server machine.

In netstat I see a process listening on the given port, but it doesn't answer.

Regards,

Javabird
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top