1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Dead : Mouse and keyboard

Discussion in 'Hardware' started by kronfeld, Oct 21, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. kronfeld

    kronfeld Thread Starter

    Joined:
    Oct 20, 2004
    Messages:
    2
    I have a problem. Its all fine during POST, no "keyboard not detected" msg

    appearing, but I cant press delete or any other keys to get into BIOS setup.

    Keyboard's "Num Lock" lights do not flash. Windows will load but both the keyboard and mouse is dead. Tried other keyboard with the same result. tried the keyboard on another PC - works fine.

    Previously the windows had a pci.sys error - "pci.sys not found." ive transported the HD to another PC and reformats the HD, and installs a fresh WINXP on it. Windows now loads fine on the new and old PC, but keyboard and mouse is dead on the old PC.

    Have a USB adapter for keyboard but same result. tried the USB ports, both 2 ports on back of PC, and 2 other ports on casing (front). So i guess shouldnt be a problem with the ports, because ive just changed the casing to new and the front ports are fresh,never been used.

    System details:
    winxp
    AMD duron 750MHz
    mobo EPOX EP-8KTA2
    128MB SDRAM PC133
    PS2 keyboard with USB adapter.
    ps2 mouse.

    some guy suggested flashing the BIOS, but i do know how to that when i cant get my keyboard and mouse to work.

    maybe, and just maybe, my PS2 keyboard and PS2 mouse ports are broken and the USB keyboard setting in BIOS is not enabled. then how?

    any takers?

    feiz kronfeld
     
  2. kiwiguy

    kiwiguy

    Joined:
    Aug 17, 2003
    Messages:
    17,584
    If the keyboard lights do not flash at boot-up, thats pretty clear indication its not going to work.

    You may be building in another problem by reformatting and loading XP on another PC though, unless the other PC is absolutely identical (motherboard etc) to the old one, as all you are doing when you boot the old one is force feeding all the wrong drivers for the motherboard. That usually always a failure.

    But that's not your problem if the problem existed before then, it's just that you have possibly added yet another layer of problems.

    Reflashing the BIOS is unlikely to be an answer, if it used to work.

    I would suspect that the I/O section of the motherboard has died, or the power source has died to that part of the motherboard.
    Could account for the pci error as well. Have you tried with all unneccesary PCI cards removed?
     
  3. Lurker1

    Lurker1

    Joined:
    Jan 30, 2001
    Messages:
    3,992
    I agree with kiwiguy.

    If the lights don't flash on power up you are missing the 5v to the PS2 ports. Have you tryed just the keyboard with the mouse unplugged? Sometimes a bad mouse can hold the voltage down. Another power supply might help but its probably time for a new motherboard.
     
  4. kronfeld

    kronfeld Thread Starter

    Joined:
    Oct 20, 2004
    Messages:
    2
    hmmm, getting a new mobo means better for me to upgrade the processor and change the RAMs. btw, thanx guys, eventhough it is still a headache but now i can sleep well knowing its beyond my capabilities to solve it.

    thanx!
     
  5. guarisma

    guarisma

    Joined:
    Jan 4, 2005
    Messages:
    5
    Hi!!

    I installed Fedora Core 3 just days ago, and I was makeing a up2date of the Kernel, then my PC freezed and I had to turn it off, It was late so I decided to go to sleep, and this morning I turn it on and either my mouse and keyboard worked at all...

    When I pressed a key the Caps/Num/Scroll Lights flashes 3 times and nothing else happens... I can here some sounds that are kind of sync with the flashing lights inside the case (that's the weirdest thing that I've seen or heard), maybe a HDD or a DVD driver, I'm not sure yet....

    I can't get into BIOS either 'cos I can't press Delete, it just won't work and the lights flashes...

    I still can boot my OS, but Fedora rise it's kudzu app for detecting changes on my hardware, but I can't see what's changed 'cos I got time out before I can press a Key (no keyboard no key...), I get to the logon screen and can't do nothing else, no mouse, no KB...

    I have a PS/2 MS Natural KB and Belkin Mouse...
    I tryed KB Only and dind't work either, I tryed an old generic PS/2 Keyboard I have and I get the same problem

    Is my PS/2 ports screw??
    Is there some kind of conflict, if yes, why it appears all sudden and not before??
    Should I try USB??
    Can I use a USB MB &/or mouse without making it to the BIOS??

    My PC is a:

    Athlon 64 3000+
    Mobo Gigabyte GA-K8NS
    RAM 512 Mb DDR 266 Mhz
    HDD 80 Gb Maxtor ATA
    HDD 80 Gb WD SATA
    GForceFX 5200 128 Mb

    Please help! :confused:
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/287176

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice