1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

default action "search" instead of "open"?! (in my computer)

Discussion in 'Windows XP' started by kioranz, Oct 26, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. kioranz

    kioranz Thread Starter

    Joined:
    Oct 15, 2007
    Messages:
    15
    here a stumper for me. . . maybe one of you knows how to fix it...

    when in my computer, if i double click on any of the drives, it opens up a search window instead of opening the folder! its sooo annoying. I have to right click and select 'open' every time.

    if i right click, the menu opens there and 'search' is on the top in bold instead of 'open'.

    i dont know how i messed it up, but if you know how to change the default action.
    PLEASE HELP!!!



    thanks in advance for any help

    -kio

    SOLVED THANK YOU THANK YOU!
     
  2. Tufenuf

    Tufenuf

    Joined:
    Jul 28, 2007
    Messages:
    2,461
    kio, Go to Start/Run and type in:

    regsvr32 /i shell32

    Click OK

    Note that the spacing is important.

    Tufenuf
     
  3. Dr. Chauncey

    Dr. Chauncey

    Joined:
    Oct 25, 2007
    Messages:
    2,393
    I had the same problem last night. I tried to change the default action in folder options but open wasn't available. There's a registry key that controls default actions too but I didn't feel like messing with it, so I just used system restore to go back a day or so. This is the solution for the same problem from annoyances.org:

    "I had the same problem and did this (back up registry first) then .... goto START, type regedit,go to HKEY_CLASSES_ROOT, Directory, shell and then delete the actions listed. Folders will now open as they used to. I also did the same thing with my C and D drives, and instead of shell, went to drive and deleted actions which resulted in the actions going back as before. Hope this helps :) "
     
  4. kioranz

    kioranz Thread Starter

    Joined:
    Oct 15, 2007
    Messages:
    15
    HOLY MOLEY!
    Tufenuf, it worked!

    thanks forever!

    thanks to you also, dr.chauncy, but tufenuf's fix was 123!
     
  5. Tufenuf

    Tufenuf

    Joined:
    Jul 28, 2007
    Messages:
    2,461
    kio, Glad to see that the problem is fixed & Thanks for posting back to let us know.

    Tufenuf
     
  6. $aunder$

    $aunder$

    Joined:
    Nov 4, 2007
    Messages:
    2
    Tufenuf,

    Thanks very much for the concise and accurate answer, I saw the same question answered over 3 pages !!!

    $aunder$
     
  7. zoyce

    zoyce

    Joined:
    Nov 8, 2007
    Messages:
    1
    Excellent stuff, Tufenuf! - glad I found this as I too was stumped. For weeks!
    Thanks.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/643863

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice