1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

default gateway troubles - crossover cable, router, internet problems

Discussion in 'Networking' started by eyeJ, Sep 29, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. eyeJ

    eyeJ Thread Starter

    Joined:
    Sep 29, 2013
    Messages:
    4
    Hello :)

    Here's what I have:

    I have a router that provides internet access and connectivity to 2 PC's over lan cables and multiple other stuff over the wireless connection.
    One of those two pc's connected over lan is my desktop computer.
    My desktop computer has 2 lan ports one is connected to the router and it's used for accessing the internet or sharing files with computers connected with the router.

    Here's what I want to do:
    I want to use the other lan connector on my desktop computer to directly connect my new laptop so that it can be set it up as a render slave.
    I need to connect it directly because it's much faster that way and the router doesn't have more than 2 lan connectors which are both used.

    I tried various ways to set up, with straight or crossed cable. I got the direct connection working but the problem is that to make it work the default gateway has to be set.
    And if the default gateway is set on desktop connection 2 and laptop connection, there is no internet access on the desktop:

    router address:
    192.168.1.1

    desktop connection 1 > with the router:
    ip: 192.168.1.120
    mask: 255.255.255.0
    default gateway 192.168.1.1
    dns: 192.168.1.1

    desktop connection 2 > for direct connection with the laptop
    ip: 200.200.1.201
    mask: 255.255.255.0
    default gateway 200.200.1.202
    dns: none

    Laptop connection > for direct connection with the desktop
    ip: 200.200.1.202
    mask: 255.255.255.0
    default gateway 200.200.1.201
    dns: none

    -----------------------------------------------------------
    If I remove the default gateway from the direct connections, it says the network is unidentified, public and unchangeable.
    Also the desktop or the laptop cannot ping each other:

    desktop connection 2 > for direct connection with the laptop
    ip: 200.200.1.201
    mask: 255.255.255.0
    default gateway none
    dns: none

    Laptop connection > for direct connection with the desktop
    ip: 200.200.1.202
    mask: 255.255.255.0
    default gateway none
    dns: none
    -----------------------------------------------------------

    How can one make the internet and the direct connection work at the same time?
    I don't want to use internet connection sharing or other stuff if not necessary.

    Laptop has Windows 8 x64
    Desktop Computer has Windows 7 x64
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,822
    First Name:
    Terry
    A reasonable solution is to just get a small ethernet switch to effectively increase the router's LAN ports.

    I don't know if there is any chance of getting your Rube Goldberg method working with public IP addresses.

    Then get a switch, as I mentioned above. The only two ways I know to do what you want are to use ICS or "other stuff" (namely, to bridge the connections, but I don't know if this will work if you are using static IP addresses for connections to the router).
     
  3. eyeJ

    eyeJ Thread Starter

    Joined:
    Sep 29, 2013
    Messages:
    4
    after a lot more digging I managed to get it working but i have to change policy to make the unidentified network a work or home / private network. I cant believe how stupidly complicated it is to make such a simple thing work. you may misunderstood what I want... I don't want internet on the laptop I just need the desktop to communicate with the laptop for rendering purposes.
     
  4. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,822
    First Name:
    Terry
    You're right, I did not understand that you did not want internet access on the laptop. In that case, just assign static private IP addresses to each machine (e.g., 10.1.1.10 and 10.1.1.20) with Mask 255.255.255.0. Or, just let the computers assign APIPAs (169.254.x.y).
     
  5. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    5,938
    You figured out that you don't want to set a default gateway for the direct connection between the PC and laptop. The reason why traffic wasn't passing between the two successfully until after you set the network type is because of the built in firewall in the later versions of Windows. Setting up the connection as a home, work, or public is invoking a default firewall template for that connection. I guess if you don't set the connection type, the firewall just defaults to least trusted or public until you set it.
     
  6. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,822
    First Name:
    Terry
    And, annoyingly, you don't always get a chance to set it and are not able to change it from Public to something else in an intuitive way. For example, if you use APIPA the network is designated Public with no chance for you to choose. Public? What does Windows/Microsoft not understand about "automatic" and "private"?
     
  7. eyeJ

    eyeJ Thread Starter

    Joined:
    Sep 29, 2013
    Messages:
    4
    Yes I confirmed the the problem is network type and nothing else. I did it by changing the local policy in Local Security Policy editor.
    The problem is that the Unidentified Public network can't be changed from public to private by default.

    Setting the Local Security Policy (secpol.msc) > Security Settings > Network List Manager Policies > Unidentified Networks > Properties > User Permissions to: "User can change location" ...doesn't seem to affect Network and Sharing Center.
    I still cant change the network type to private.

    Setting the Local Security Policy (secpol.msc) > Security Settings > Network List Manager Policies > Unidentified Networks > Properties > Location type to: Private... works but it's not the best thing to do.
    Any ideas how to change the unchangeable Network Location without affecting the global policy defaults for all unidentified networks?
    My biggest concern is if it affects wireless networks as-well?
     
  8. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    76,822
    First Name:
    Terry
    What I eventually discovered (using APIPA; probably same will work with static IPs) is that I could try to access a folder in the remote PC and get a popup with a big warning but permitting me to allow file sharing on all public networks or on just this one (my choice). I've now done this several times with Windows 7 to Windows 8, each time just for copying one large file.
     
  9. eyeJ

    eyeJ Thread Starter

    Joined:
    Sep 29, 2013
    Messages:
    4
    Thanks for the quick reply. I will try that. To see what happens :)
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - default gateway troubles
  1. SWkat
    Replies:
    12
    Views:
    204
  2. jackjack81
    Replies:
    3
    Views:
    289
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1109510

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice