1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

default_exe.reg revoked my ability to open .exe files with anything.

Discussion in 'All Other Software' started by MaxxS, Mar 19, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. MaxxS

    MaxxS Thread Starter

    Joined:
    Mar 19, 2011
    Messages:
    4
    I accidentally made the default program that .EXE files open with cmd, and had to use default_exe.reg to repair this. However, I can't open .exe files with any programs anymore. I'm using Windows 7 Home Premium. Is there any easy way to solve this?
     
  2. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,064
    Not sure what you did exactly.


    Try this fix: EXEFIX

    Unzip the fix and extract the .REG file to the Desktop. Right-click the .REG file and choose Merge. Note that you need to be an Administrator to apply this fix.

    Reboot the computer.

    If the fix only opens as a text file, right-click it and select Open With > Choose Program... Then, select the Registry Editor.

    If the Registry Editor is not in the list, browse to C:\WINDOWS and select regedit.
     
  3. MaxxS

    MaxxS Thread Starter

    Joined:
    Mar 19, 2011
    Messages:
    4
    That didn't do anything. Is there anything I can clear up?
     
  4. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    That's the way it is supposed to be. You are not supposed to open exe's with anything else. Try Unassoc. Unzip the file and rename unassoc.exe to unassoc.com. Then run it.
     
  5. MaxxS

    MaxxS Thread Starter

    Joined:
    Mar 19, 2011
    Messages:
    4
    That program tells me that I am a user despite it being opened as administrator, so it didn't work.
    EDIT: Sorry, I missed that you said to change it to .com. However, the remove file association button does not work, as there is no file association for .exe files.
     
  6. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    That is the way it is supposed to be. Did it run as an exe? What happened when you clicked on it? If it did, then you have a different problem.

    Can you explain in detail exactly what you did? What makes you think you changed the association to CMD (since it has none now)?
     
  7. MaxxS

    MaxxS Thread Starter

    Joined:
    Mar 19, 2011
    Messages:
    4
    I chose "open with" CMD for an .exe file that was meant to be opened with CMD, but didn't uncheck the "always use the selected program for this kind of file" box so every .exe file opened with CMD. I used default_exe.reg, which I got from Microsoft's website, which removed the default file association for all .exe files, but I can't use "open with" on .exe files anymore, so I can't open the .exe files with CMD anymore, at least not through Windows Explorer.
     
  8. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    You will end up with problems if you try to use OpenWith with exe files. You are not supposed to open them with anything at all and that option should not be available. You "open" exe files by clicking on them, not by using cmd.

    If you want to use cmd to open a file, you open a command window first, then navigate to the file you want to open inside that window. If you do not know how to do this, then you probably shouldn't be trying to open files that way.

    So, in other words, you have no problem, since OpenWith is not supposed to exist in the menu for exe files.
     
  9. jeanluc1986

    jeanluc1986

    Joined:
    Apr 29, 2011
    Messages:
    1
    Quote: "So, in other words, you have no problem, since OpenWith is not supposed to exist in the menu for exe files."

    I beg to differ, if only by utilizing logic to the conversation thus far. . .

    Also, I am experiencing the same problem, though in my case, I believe I deleted the wrong thing when manually deleting a virus. I saw that in the Task Manager menu the virus showed up as "rng.exe" and so I searched for it, and deleted everything I could find that had anything to do with it. Now, when I try to open .exe files, I am presented with an "Open With" menu, and I cannot figure out what to do with my computer now.

    P.S. - I apologize if this thread is necro-ed, but I am going a little crazy about this problem. . .:confused:
     
  10. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,064
    Try this fix for Windows XP: EXEFIX

    Save the .reg file to your desktop. Double-click it to merge it to the registry.

    Reboot.

    If the fix only opens as a text file, right-click it and select Open With > Choose Program... Then, select the Registry Editor.


    If the Registry Editor is not in the list, browse to C:\WINDOWS and select regedit.
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/986888