1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Dell Latitude D520 memory slot doesn't work

Discussion in 'Hardware' started by rayi23, Jul 11, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. rayi23

    rayi23 Thread Starter

    Joined:
    Jan 16, 2005
    Messages:
    111
    Hello. I have this odd problem in my Dell Latitude D520 core2duo where one of the memory slots isn't working anymore. Just yesterday the Laptop would not startup but lights on the front panel came on, so I suspected a memory issue. The D520 has a slot underneath the keyboard for memory, as well as underneath the laptop. When ever I put memory in the slot under the keyboard, it won't startup. I tried various memory known to work. I even took the memory from underneath the laptop and placed it under the keyboard because it worked underneath. But once I placed the memory in the slots under the keyboard, it would not startup. I would just get three green lights next to the power key. One stayed, the other 2 blinked; they all eventually stopped entirely. Once I removed the memory, it would start up. I tried cleaning the memory slot with an air can. I've never encountered this before. For now, I just run with 2 gig memory stick underneath the laptop. It works fine. I am assuming a motherboard issue. Any suggestion greatly appreciated.
     
  2. Gr3iz

    Gr3iz

    Joined:
    Mar 9, 2009
    Messages:
    99,015
    First Name:
    Mark
    Sure sounds like the socket is bad, or the memory controller. You may have to live with a single DIMM in the bottom slot.
     
  3. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    79,815
    First Name:
    Frank
    The Dell Latitude D520 laptop supports up to 4 GB of RAM - up to 2 GB in each slot.

    This is the recommended 1 GB and 2 GB module for it:

    200-pin DDR2 PC2-5300(DDR2-667), 1.8 volt, CL=5, unbuffered, non-ECC

    --------------------------------------------------------
     
  4. personperson

    personperson

    Joined:
    Jun 24, 2006
    Messages:
    67
    ^^^ This guy really knows his stuff. So very helpful. I think he replied to my thread too with something equally as relevant to what was in my post.

    The same thing happened in my old laptop after I tried installing a version of Linux (Damn Small Linux.) No idea why or how it happened, but I was forced to just live with one stick of ram for the remainder of the time I kept it. I don't know for sure, but I'd imagine the laptop is build in a rather 'proprietary' fashion and it would be extremely difficult to fix the issue yourself because it most certainly is the hardware/motherboard.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1103329

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice