1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Dell Steady Amber Power Light

Discussion in 'Hardware' started by quarter29, Feb 3, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. quarter29

    quarter29 Thread Starter

    Joined:
    Feb 3, 2006
    Messages:
    6
    Hello, My Dell 2400 computer that I've had for 2½ years went completely dead. I replaced the power supply and now there is only a steady amber power light right at power up. Never gose to green. No video or drive lights come on. None of the diagnostic leds are on. Went to the Dell support page and did the unplug boards and cables steps, etc. until I got to the "contact a tech" part. Computer is out of warranty. Any suggestions? Is the motherboard bad?
     
  2. mahfuz.ca

    mahfuz.ca

    Joined:
    Feb 3, 2006
    Messages:
    4
    Have your tried to stripped your system down to MB and Processor( means removing IDE,FDD,HDD Cables,RAM aswell),Look for beap codes from system if any beep heard trouble shoot memory, if no beep heard troubleshoot MB and Processor .Try reseating RAM one slot at a time in diffrent module, Check for PSU fan,if necessary Reset Processor(Careful not to break PINs)
     
  3. quarter29

    quarter29 Thread Starter

    Joined:
    Feb 3, 2006
    Messages:
    6
    Yes, I stripped it down to MB and Processor. No beep codes. Fans are working. Only have one memory module that was reseated. I will reseat the processor and see what happens. If there is still a steady amber light, is there any way to tell if it's the MB or processor that's bad?
     
  4. Rockn

    Rockn

    Joined:
    Jul 29, 2001
    Messages:
    21,189
    I had the same issue except it was a power supply. From the looks of it your motherboard is dead or your new power supply is dead. Test the power supply in another PC just to make sure.
     
  5. dustyjay

    dustyjay Jay

    Joined:
    Jan 23, 2003
    Messages:
    12,166
    Dell "Used to use" Proprietary Powersupplies. In otherwords while they claimed that they were Fully ATX Compliant, the wiring to the Motherboard connector was different than a standard ATX power supply. Unless you got a direct replacement from dell for your power supply, compare your new power supply to the original to amke sure that the wires on both motherboard plugs match each other. If they are the same I would make a guess at either the new power supply is bad out of the box or that the Motherboard or processor are dead.
     
  6. mahfuz.ca

    mahfuz.ca

    Joined:
    Feb 3, 2006
    Messages:
    4
    Well I forgot to ask did your system ever worked after replacing power supply???I am eying into MB, you have 4 LEDS in the back of the system Panel Marked as ABCD,Could you provide me Color Codes?//Have you called Dell Help line???They have the best Tech support,I have experienced.
     
  7. sph_12

    sph_12

    Joined:
    Sep 30, 2004
    Messages:
    68
    quarter29,
    I have worked with new Dell computers before, and found that the amber light usually means bad power supply. In the past, Dell power supplies were proprietary, but I don't know if they changed that. You should check the new power supply you just bought to make sure it works.

    A couple of years ago, I stumbled across an adapter that allowed standard ATX psu's to be used in Dell PC's requiring proprietary psu's. If you can find one of these, I highly suggest it, because Dell psu's will be expensive.

    On a different note, when you strip out your PC and turn it on, make sure 1 stick of RAM is installed. If not, it will hurt your PC.
     
  8. quarter29

    quarter29 Thread Starter

    Joined:
    Feb 3, 2006
    Messages:
    6
    Thanks for all the replies. The processor was reseated and there's still a steady amber light. The 4 LEDs on back have no color. I was told the power supply was from a good computer, so the only thing left is the MB or processor?

    Mark
     
  9. mahfuz.ca

    mahfuz.ca

    Joined:
    Feb 3, 2006
    Messages:
    4
    NO LEDS in the back means either Power supply or MB.power supply from outside may not work( unless they are exactly similar).Have you tested this power supply in a known good diffrent system? or wires/Pins looks exactly same? Some how your MB is not getting power as there are no LEDS in the Back,I am positive you are trying with a bad power supply. power supplies are not expensive about 30-40 bucks.is your power supply fan spinning?? if no 1st thing i would look Power supply, do you have any kinda Flea lit in MB?? AMBAR or Green?
     
  10. quarter29

    quarter29 Thread Starter

    Joined:
    Feb 3, 2006
    Messages:
    6
    The new power supply wires are exactly the same as the bad power supply. The flea LED is Green. I still have the steady amber LED. The only difference with the new power supply, is the power supply fan is now working. Mark
     
  11. mahfuz.ca

    mahfuz.ca

    Joined:
    Feb 3, 2006
    Messages:
    4
    Dimension 2400 uses Micro ATX technology,2400 has no LEDS in the Back of the system,Since PSU fan is spinning and flea lit is green I would say MB, however i would recommend calling DELL helpline if they have anything diffrent than we have discussed.
     
  12. quarter29

    quarter29 Thread Starter

    Joined:
    Feb 3, 2006
    Messages:
    6
    Thanks for the help.
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/439584