1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

DELL with VISTA OS Problem Connecting to LINKSYS Wireless Router

Discussion in 'Networking' started by gecko1789, Apr 10, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. gecko1789

    gecko1789 Thread Starter

    Joined:
    Apr 10, 2009
    Messages:
    2
    I have 2 Dell notebooks running XP that connect to a Linksys WRT54GP2 wireless router with no problems. The security is set to WPA PSK with the WPA algorithm to TKIP.

    I also have a new DELL notebook running on Vista that won't connect wirelessly to the router - it can see it, but when I try to connect, it comes up with an error message '802.11 authentication failed due to status code 13. Resonding station does not fit the specified authentication algorithm'

    I tried connecting the DELL Vista notebook to the router via a cable - it works fine.

    I also tried disabling security so there was none, and it also worked fine. So the problem seems to be with the security algorithm.

    I have searched on the net and a lot of people seem to be having problems with the DELL-VISTA-Linksys combination, but i haven't found any answers.

    Can you help??:confused:
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    First off, make sure that 802.1x authentication is disabled on the wireless adapter. If so, try the following changes.


    Changes that may help to increase the compatibility of Vista with older networking devices:



    Disable the IP Helper service:

    1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
    2. Scroll down to the IP Helper service, right click on it and select Properties
    3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
    4. Then click on "Stop" to stop the service from running in the current session
    5. Click OK to exit the dialog



    Disable IPv6:

    1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
    2. Right click on each network connection and select "Properties"
    3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
    4. Click OK to exit the dialog

    NOTE: You should do this for each network connection.



    Disable the DHCP Broadcast Flag:

    Link: http://support.microsoft.com/default.aspx/kb/928233
    1. Hold the Windows key and type R, enter regedit and press Enter.
    2. Locate and then click the following registry subkey:
    3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
    4. In this registry path, click the (GUID) subkey to be updated.
    5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
    6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
    7. In the Value data box, type 0, and then click OK.
    8. Close Registry Editor.
    NOTE: You should do this for each and every GUID subkey.
    NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.




    The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.
     
  3. gecko1789

    gecko1789 Thread Starter

    Joined:
    Apr 10, 2009
    Messages:
    2
    Hi John,

    Thanks for your reply.:)

    Thanks for the instructions with disabling IPv6 - very clear.

    But unfortunately I have stumbled at the first point. Exactly how is 802.1x authentication disabled? :confused:

    Also, please excuse me if I am showing my ignorance as i am new to this, but isn't the authentication process doing something like confirming "yes, we do have an 802.1x network here"?

    The laptop will connect if I turn off the security, so I would have thought there is some issue with the Windows Vista XP machine not being compatible with WPA-PSK, or perhaps needing some setting to allow it to work properly???

    :confused::confused:

    Gecko
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/817461

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice