Device Manager empty. USB ports not detecting

This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.


Thread Starter
Jan 11, 2006
I'm about to explode with frustration!

Problems started when USB ports seemed to spontaneously stop working. Then Device Manager window is empty. Nothing shown at all. Also My Computer takes ages to load and system often seems to hang

Have run every spyware and virus scan possible. Followed instructions on Annoyances forum but still no joy. PnUP is switched on.

3.4GHz P4
1024 MB
750GB in 1x 200GB and 1x 500GB
Bulldog 8MB connection through LAN to router
Norton Internet Security 2006
3 xDVD writers


Thread Starter
Jan 11, 2006
I have a partial resolution to my problem!

Thanks to everyone who offered help.

First option was check that PuNP was started - OK. Later I discovered that Universal PuNP must NOT be started!

Second option was Aproposfix which I assume is to get rid of some specific spyware/adware/malware.

Third was I tried editing some permissions in the registry but I didn't really understand what I was doing.

Fourth was I ran sfc/scannow - whatever that is!

Also system was hanging on startups and shutdowns, sometimes needing the big switch to get out of it. Now you can click on IE or My Computer or Control Panel and it takes ages for them to load. Usually I find myself with about five instances of each all loading at once.

Frequently web links won't work. The only thing I can do is avoid a left click - use right clicks to save shortcut and then paste it into address bar. I have tpo switch back and forth betwen web browsers using teh Task Manager. OIften the Task Manager itself freezes with the button still "pressed down".

I've also been using my SpeedUpMyPC utility which allows you to give CPU priority to a particular window. A combination of this, Task Manager and a hell of a lot of patience just about keeps me going

Oh, and I updated all my chipset drivers along the way.


Oh joy! The printer is working too. The solution? It was to do with permissions. I had to spend a lot more time and give a lot more thought to it. (I still don't understand it properly). It's in HKEY Local Machine "Enum"
whatever that means?

So many thanks to the forum which first gave me the idea for that fix.


Some things are better like loading IE or My Computer or Control Panel. They're still slow though and I can still find myself with loads more browser windows open that I need. On IE though browsing still suffers froim the same problem. Links won't work. I have to copy shortcut and paste into another window.

Java linlks often don't wprk eiuther. I uninstalled and re-installed Java. Maybe there's some slightimprovement but browsing is still a pain.

So now it comes down to a performance problem, mainly in IE.

Shall I uninstall and reinstall IE?

Why has this happened. Could Malware/spyware viruses be reponsible?

Any help gratefully received and because it's only fair, I'll make sure every forum gets a full report when it's all fixed (It will be won't it?)

System Description

INTEL P4 3.4GHz, socket 775
ASUS P5GD1-VM motherboard, onboard LAN (Intel Pro 100), onboard graphics and audio disabled
American Megatrends BIOS version 1010.005
2 x 512MB PC3200 400MHz DDR
200GB Maxtor serial ATA drive - C
500GB Seagate serial ATA drive - D
Samsung/Toshiba DVD writer - E
Sony Q28A DVD writer - F
Sony DRX-810UL external DVD writer on USB - G
ATI All in Wonder X800XL graphics card
Creative Soundblaster XFi Xtreme Music sound card
Logitech Dinovo Media keyboard, seperate keyboard and numeric panel/remote with mouse on powered USB hub
Logitech Communicate STX webcam

I run Windows XP Home Service Pack, fully updated. I defragment with Perfect Disk at least once per week.

I use the following security software:

Norton Internet Security 2006
Ad-Aware SE
Spyware Doctor
Spy Bot
Microsoft Antispyware
Spyware Blaster
Spy Sweeper

All are updated regularly and full scans performed at least every other day.

I also use Registry Mechanic at least once per day. And this episode has added about a dozen other utilities to my amoury.
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online