1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

dfrgntfs.exe when idle

Discussion in 'Windows XP' started by kwdrum42, May 17, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. kwdrum42

    kwdrum42 Thread Starter

    Joined:
    Oct 22, 1999
    Messages:
    66
    I've noticed recently that Windows XP seems to be defragging my disk every time my computer is idle for about 10 minutes. Normally, this wouldn't bother me, since I don't mind having my disks fit and trim. However, if there is music playing from the hard disk in any media program (.mp3/.ogg files in this case) the defragging process causes the music to "skip": there are gaps in the audio. It's doesn't happen with CDs, so I suspect it has something to do with the defragging process hitting the hard disk pretty hard and narrowing available bus bandwidth. This is highly annoying; it effectively means I can't have my computer playing music while I do something else.

    How on earth do I turn off XP's autodefrag option? I've seen several posts with the same problem here, but no solutions. I do not have any third-party disk management tools installed, and the Indexing Service is off.

    Thanks in advance for your help. You guys have the best Windows support forums around.

    - kwdrum42
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    You must have Diskeeper. Dfrgntfs is one of its components. Open Diskeeper and set the schedule. I find it easiest to set the schedule to defrag whenever the screensaver is on.
     
  3. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Sorry. I see that XP has its own dfrgntfs. You might try looking in Scheduled Tasks to see if optimization is scheduled for idle time.

    You might also try disabling the Indexing Service. It is usually set to "Manual" and starts during idle time. If you don't use its search functionality, there is no need to run it, anyway.
     
  4. kwdrum42

    kwdrum42 Thread Starter

    Joined:
    Oct 22, 1999
    Messages:
    66
    Nothing in Task Scheduler.

    I had the Indexing Service set to "Manual" -- when I disabled it, the defragging stopped, and so did my problem.

    My question, though, would be if there is a way to stop the idle defragging process without disabling the Indexing Service. It seems like there's an awful lot going on behind the scenes in Windows XP that I don't know about, need, or even want, and it's difficult to keep valuable things running without keeping the junk running (the indexing service / defrag-when-idle is a good example). I really wish Microsoft was a little more open about things like this for the power users. It *is* possible to cater to the lowest common denominator without alienating those of us who know what we're doing.

    I'll quit ranting, though, because my problem is solved. :)

    Thanks for your help.

    - Kevin
     
  5. Yawn

    Yawn

    Joined:
    Sep 16, 2007
    Messages:
    1
    Hope this helps dudes:

    Goto [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OptimalLayout]

    If no DWORD for "EnableAutoLayout" then create one

    Set to 00000001 for defrag when idle
    Set to 00000000 for no defrag when idle

    Or d/l tweakui from m$ and under the General tab you can see Optimize Hard Disk when Idle - untick it.

    Cheers :)

    Yawn.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/230010