1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

DHCP Client Service fail to Start

Discussion in 'Windows Vista' started by DavidPCS, Sep 3, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. DavidPCS

    DavidPCS Thread Starter

    Joined:
    Sep 3, 2009
    Messages:
    16
    Hi Guys -

    I have been trying to do research on this issue. This morning my Wife's Computer failed to connect to the internet. Listed below are the System Specs, Current Issue and routes taken to investigate issue.

    Windows vista Home Basic
    SP 1
    E machine model: T3646
    AMD Sempron (tm) LE-1250 2.20 GHz
    RAM 1.00 GB
    System Type: 32-bit Operating System



    Issue:
    Unable to connect to the Internet

    Cause:

    DHCP Client Service failed to start.


    Investigated:
    MSCFIG - DHCP Client, start pending

    Manage Services - DHCP Client starting (unable to access commands when right clicked-allgrayed out.)

    Control Panel:
    Network and Sharing/ Local area Connection
    (The dependency service or group failed to start.)


    We are looking for a resolution to this matter. Thank you in advance for your suggestions.

    Last Note. We do Share an Internet Connection via a D-link Router. My Computer is able to go online without any problems.
     
  2. Sponsor

  3. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    See if these help.

    From a Johnwill postConfigure DHCP for Windows Vista.
    1. Click on the Start menu, and select Control Panel.
    2. Click on Network and Internet. (Skip this step if you do not see this Control Panel item.)
    3. Click on Network and Sharing Center.
    4. Click on Manage network connections.
    5. Right click on Local Area Connection and choose Properties. If Windows say it needs your permission to continue, click Continue.
    6. Select Internet Protocol Version 4(TCP/IPv4) and click Properties.
    7. Select Obtain an IP address automatically.
    8. Select Obtain DNS server address automatically.
    9. Click OK to close the TCP/IP Properties window.
    10. Click OK to close the Local Area Connection Properties window.
    11. Click Close to close the Network Connections window.
    12. Click Close to close the Control Panel window.
    13. Restart your computer.

    Hold the Windows key and press R, then type devmgmt.msc

    Please respond to all the following steps.
    1. Under Network adapters, please tell me all the devices listed.
    2. Are there any devices under Network adapters that have a red x displayed?
    3. Also, are there any devices anywhere in the Device Manager display with yellow ? or ! displayed?





    Check your Services are Started on all PCs:
    • COM+ Event System (for WZC issues)
    • Computer Browser
    • DHCP Client
    • DNS Client
    • Network Connections
    • Network Location Awareness
    • Remote Procedure Call (RPC)
    • Server
    • TCP/IP Netbios helper
    • Wireless Zero Configuration (XP wireless configurations)
    • WLAN AutoConfig (Vista wireless configurations)
    • Workstation

    Note: You can check the services in Control Panel, Administrative Tools, Services.

    All of these services should be started, and their startup type should be automatic (or perhaps manual).

    If a service is not running, open it's properties and check the dependencies. Check each of the dependencies and see which one is preventing the service from running. Checking the event log is also a good idea here, there may be clues to what is failing.
     
  4. DavidPCS

    DavidPCS Thread Starter

    Joined:
    Sep 3, 2009
    Messages:
    16
    Thank you for your quick response.

    I should had stated in my original post I did investigate Device Manager. There where no dis functional items listed.

    I did follow you instructions -

    Everything was set to Auto attain, so I clicked off and click them back on.
    re booted check Dev Manager

    Check Manager / Services
    Tried to Start DNS client got this message:
    Error 10107: A system call that should never fail has failed.
     
  5. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    OK;Let's try this :

    Stack repair for XP and Vista.
    Courtesy of Johnwill of the Networking forum.

    TCP/IP stack repair options for use with Windows Vista.

    Start, All Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

    In the command prompt window that opens, type type the following commands:

    Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

    Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

    Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

    Reboot the machine.
     
  6. DavidPCS

    DavidPCS Thread Starter

    Joined:
    Sep 3, 2009
    Messages:
    16
    I attempted to run the resets. Here is the message I received.

    Initialization function inithelperdll in NSHHTTP.DLL failed to start with error 10107.
     

    Attached Files:

  7. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    I have done quite a few searches and your error appears to be some kind of winsock corruption.
    If that is the case,I'm afraid I am a bit over my head on this one.Quite a few of the hits that I found needed some registry manipulation.
    Hopefully someone else on this forum will have some ideas on this.
    Sorry that I could not assist you more
     
  8. DavidPCS

    DavidPCS Thread Starter

    Joined:
    Sep 3, 2009
    Messages:
    16
    Hey Pedorguy -

    Thanks for your help! This error does seem to be an Issue. However I was able to resolve it.


    Here is what I did:

    I booted up in safe mode by pressing F8
    I run a SFC scan run/ (type) SFC /scannow
    To check and try to repair any and all bad data.
    Scan was successful in the fact that I did not need an Install Disk.
    Restarted in Safe Mode again - This time on the 1st prompt to ask what mode to boot up I selected "Repair Computer"

    From the Repair Computer menu I select a system restore. - The Restore had a memory error an d failed.

    I then rebooted back into safe mode selecting the Repair Computer option and ran a Memory test and repair. Test and Repair were both successful

    I rebooted again in safe mode selecting the Repair Computer
    And went back to System restore.

    To my surprise the system restore was complete successfully! After about 20 minutes my computer rebooted itself and had an Internet Connection!

    After doing alot of reading regarding this issue, I had not read anywhere were Sys Restore was suggested and worked. - So if this comes up again Try suggesting that fix. ( The Repair Computer Prompt may have been built in by E machine - Not sure)

    I think this issue was sparked by me trying to clean up my Wife's computer. I had ran Spyware Terminator which is for the most part a pretty streamline program - But on her system it would hang up on 65-85% and never completing. From what I read Winsock error, DHCP failure can come from get this "REMOVING SPYWARE!!!!" WTF???

    And if you're just trying to keep a clean system BAM! you get hit with a Major Critical Issue.

    Well It's been an Exciting day at my Housing! Last night the Dishnetwork Box went out. This morning the Internet and all on our 3rd year Anniversary. What an exciting way to spend 3 years of married bliss huh?
     
  9. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Hey.Glad you got it resolved.You are correct.Your fix path was a bit bizarre ,but the important thing of course is that you fixed it.
    Great job.
    You can mark your thread solved using button at top left.
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/857926