1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Diablo 2 graphic problem.

Discussion in 'Games' started by MrSlisk, May 13, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. MrSlisk

    MrSlisk Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    57
    Hello!

    When I play Diablo 2(+ expansion if that matters) I get these:

    [​IMG]

    Really annoying, and when I'm playing, those are white.
    I figured out that games act like that on my computer when they are 16-bit color, on 32 bit it works perfect!

    anyone know how to make them disseppear?:p

    EDIT: forgot to add specs.
    I run windows vista x86 with NVIDIA GeForce 8800GS (tell me if you need more information)
     
  2. wiley8425

    wiley8425

    Joined:
    Nov 11, 2007
    Messages:
    448

    Run in 32 bit. For some reason Vista doesn't work with 16 bit for older games properly. I have similar problems with other games not displaying like they should. 16 bit is supposed to be higher compatibility, but I think that is under XP or older OSes. Vista seems to generally perform poorly display wise unless its set to 32 bit. Your card shouldn't have any issues with running in 32 bit either.
     
  3. MrSlisk

    MrSlisk Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    57
    And how do I set it to 32-bit? :)
    I can't change it in the diablo 2 options.



    EDIT:
    When I run in window mode, those pixels aren't there, but playing in a window isin't just the same feeling :(
     
  4. Courtneyc

    Courtneyc

    Joined:
    Dec 6, 2003
    Messages:
    1,906
    Go into a game. For Video Options, set the highest resolution, Lighting Quality to High, and Blended Shadows, to On. If you play in full-screen, turn Perspective On. Be aware that the highest resolution you can get is 800x600. The game looks crappy with a large monitor and horrible with a wide-screen.

    Also note that your video card works better at 32-bit color. None of the accelerator drivers on the card work in 16-bit so the card is actually slower.

    Courtney
     
  5. MrSlisk

    MrSlisk Thread Starter

    Joined:
    Mar 4, 2009
    Messages:
    57
    Courtney:

    I have all the settings that you said that I should have, but I still have those pixels.
    *Is it possible to run Diablo 2 in 32-bit colors?* It's wierd that I have them at full-screen and not in windowed mode.

    Thanks
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/826689