1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Diablo II/Expansion Run Issue

Discussion in 'Games' started by danielc, Apr 29, 2007.

Thread Status:
Not open for further replies.
  1. danielc

    danielc Thread Starter

    Joined:
    Apr 29, 2007
    Messages:
    2
    Hey,

    Firstly - this issue is occurring on a Macintosh (iMac latest gen). So I am not sure if you can help (I'm asking on behalf of a friend). But maybe this is just a generic issue that can have a simple answer regardless of platform.

    When installing Diablo II and Expansion from the discs (he owns it twice as his XP laptop wouldn't read a disc on his first copy) everything goes great. But when he runs the game it's not so great. The intro Blizzard videos play fine. But when it gets to the title/first menu screen it goes a bit whacky.

    Here is a screen shot:
    http://img.photobucket.com/albums/v487/13161666/diabloiiscreen1.jpg

    I assumed it could possibly be his display resolution as he's using one of those 21" or so widescreen macs. But changing that to suggested resolution didn't fix the issue. The games ARE mac compat as written on the box/discs.

    If you manage to blindly find the character creation button through the boxiness then it will continue to show up random repeated boxes.

    Have you experienced something like this before? I can't imagine it being the drivers as the computer is new and the game is relatively old. His card slaughters the recommended one.

    He has tried using both copies he owns. But the same happens with both.

    Thank you for any help you may be able to provide!
     
  2. danielc

    danielc Thread Starter

    Joined:
    Apr 29, 2007
    Messages:
    2
    Issue fixed through changing renderer from OpenGL to Software. A Pentium Intel qwerk, I guess.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/568124

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice