1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Diablo II Installation Issue

Discussion in 'Games' started by Sylar, Nov 2, 2007.

Thread Status:
Not open for further replies.
  1. Sylar

    Sylar Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    2
    I recently upgraded my computer to Vista Ultimate and when I inserted my D2 disc and error message popped up saying:

    No program start menu found.

    I searched on-line for a while and found a fix:

    1) Go to Start > Run > type regedit
    2) Navigate to "HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\Shell Folders"

    if there is no string in there called "Programs" put that in with the value:

    C:\\Users\\%USERNAME%\\AppData\\Roaming\\Microsoft\\Windows\\Start Menu\\Programs


    After using this fix I re-inserted my disc, and this time the D2 loader appeared. I've tried all three installation choices and it keeps messing up at the same place. I choose an installation option, enter my name and serial key (yes, it is valid), and the box asking where the game would be installed pops up. The default is:
    C://Program Files/Diablo II/

    I select ok and get this error:
    Error in script file SetupDat\inst.ins, line 14: undefined symbol (desktop).

    Then the installer closes. I have looked on-line and can't find a solution to this problem. Can anyone help me out with this?
     
  2. McTimson

    McTimson

    Joined:
    Aug 15, 2002
    Messages:
    5,577
    I searched for other errors, and there are definitely issues with Vista and Diablo II, so you're not alone. I found this post, which is basically the same thing you just did, but with a little bit of extra info, it may be worth trying that.

    Otherwise, I would try running it in compatibility mode. In My Computer, right-click the CD drive, and hit open, then right-click each .exe file in there, hit Properties, and run them in Windows XP compatibility mode.
     
  3. Sylar

    Sylar Thread Starter

    Joined:
    Nov 2, 2007
    Messages:
    2
    I fixed it. A while back I had two user accounts on my computer, one limited and one admin. I got a virus on my limited account. I eventually got rid of the virus, but it really messed up my limited account, so I moved all of my files over to the admin account and deleted the limited account.

    Recently with D2 not working, I decided to create a new full administrator account and try installing it with that account and it installed. I installed the expansion pack, upgraded, and patched, and when I tried to play it gave me an error pop-up box with a whole bunch of question marks in it. Since I have my original discs (which makes this legal) I found a no-CD crack for the game's .exe and it works perfectly now. Weird.

    Thanks for replying.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/647074

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice