Did System Restore Get Moved?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

patmac

Thread Starter
Joined
May 14, 2004
Messages
1,063
Hi,
Been using System Restore for a long time. Today I went to create a Restore Point prior to installing an application, and, I can't find it. It's definitely not in it's usual place. I tried to step through where I go for it, such as Control Panel->System and Security.....and that's when I get lost. Here's my system info and any help will be appreciated.

Tech Support Guy System Info Utility version 1.0.0.9
OS Version: Microsoft Windows 10 Home, 64 bit, Build 19043, Installed 20200801104039.000000-300
Processor: Intel(R) Core(TM) i5-3340 CPU @ 3.10GHz, Intel64 Family 6 Model 58 Stepping 9, CPU Count: 4
Total Physical RAM: 8 GB
Graphics Card: Intel(R) HD Graphics
Hard Drives: C: 929 GB (733 GB Free);
Motherboard: Dell Inc. 084J0R, ver A00, s/n 6VW9NY1.CN7016338301DQ.
System: Dell Inc., ver DELL - 1072009, s/n 6VW9NY1
Antivirus: Windows Defender, Enabled and Updated
 

patmac

Thread Starter
Joined
May 14, 2004
Messages
1,063
Found it by typing in System Restore in the search box.....it's definitely been moved....sorry for the trouble.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top