dimension c521 fails to start up?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

tonypham

Thread Starter
Joined
Aug 3, 2010
Messages
92
It was working perfectly before but ever since returning from winter break it now can't make it half passed the bios startup. I can't even enter the Setup or the Boot menu. This honestly came out of no where.
 

tonypham

Thread Starter
Joined
Aug 3, 2010
Messages
92
apparently it's 2,3,4

A possible USB failure has occurred.

Reinstall all USB devices, check cable connections, and then restart the computer.

I'm not sure how i'm supposed to reinstall USB devices when I can't even start the computer pass bios tho.
 

dai

Joined
Mar 6, 2003
Messages
11,198
replug usb back one at a time to try and isolate the problem one
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top