1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Disable automatic reboot after Windows Updates?

Discussion in 'Windows XP' started by gurutech, Jun 14, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. gurutech

    gurutech Thread Starter

    Joined:
    Apr 23, 2004
    Messages:
    2,960
    How can I prevent a PC from automatically rebooting after the Windows Updates have completed?

    I know when I am using the computer, I can click the "Restart Later" box that comes up at the most inopportune times, but when I have the PC "locked", it still reboots in the middle of the night.

    I have a server that does NOT do this, but a couple XP boxes that do. Is there a reghack that can be done to make the updates on the XP boxes act the same as a server?
     
  2. Skydawg

    Skydawg

    Joined:
    May 27, 2007
    Messages:
    205
    Right click my computer, click on properties, there is an Automatic Updates tab, click on that, in there there are several options, one is download but do not install, which will let you install and reboot when you want to. :)
     
  3. ozrom1e

    ozrom1e

    Joined:
    May 15, 2006
    Messages:
    11,849
    The restart windows is needed for some of the updates and is part of the windows update process for some of the updates to finish installing. I have the same problem but to solve it I do windows updates when I am doing nothing else. Solution is to save and close everything that you are doing then do the updates they go much faster.
     
  4. Skydawg

    Skydawg

    Joined:
    May 27, 2007
    Messages:
    205
    After I read my post I thought...is that really what he was asking. :) Yeah, Oz is correct and if your server recieves updates, installs them and never reboots, then it's not acutally getting them installed.
     
  5. bamservices

    bamservices

    Joined:
    Dec 23, 2004
    Messages:
    8
    I have set my Automatic Updates to the (Download updates for me, but let me choose when to install them).

    This way the system will not reboot when I am in the middle of something. Since I have done this, it has stop rebooting when downloading up dates. I have had on occassions only seen one option after the download and that was to restart. So I just left it until I was done doing what I needed; then rebooted.

    Watch the Video Tutorial on Setting the Automatic Updates at:
    http://www.lwbs.com/_windowsxp.html
     
  6. gurutech

    gurutech Thread Starter

    Joined:
    Apr 23, 2004
    Messages:
    2,960
    No offense, but you guys are missing my point. I do have my XP's set up to download but not install. When I finally get around to install them, it wants me to reboot when it's done, but I don't want to reboot at that time, because I am doing other things on the computer that I can't get out of at the moment. So I simply click the "Restart Later" button whenever I am prompted.

    The problem is that when I "lock" the computer (like when I go to bed), the next morning, the PC has rebooted, and I lose all the stuff I was working on (except Firefox, which allows me to "restore session".)

    My server doesn't reboot in the middle of the night, and I can only presume that it's because it's a server, but the workstations reboot. There's gotta be a way to prevent XP from rebooting.
     
  7. Skydawg

    Skydawg

    Joined:
    May 27, 2007
    Messages:
    205
    Said that :) :p :D

    Just a thought, save and close your programs, so when it does reboot, you won't have a problem.

    Servers don't reboot because they are servers, serving clients, and could possibly mess a lot of things up if they just up and reboot. They aren't monitored like an XP machine, as people don't usually sit at a server and work, like you would a PC. There may be a regedit, but I don't know it, anyone know?
     
  8. devil_himself

    devil_himself

    Joined:
    Apr 7, 2007
    Messages:
    4,910
    Go To Run > MMC > Hit Enter

    At “Console1” Select “File > Add/Remove Snap-in”
    “Add/Remove Snap-in” Click on “Add”
    Add Standalone Snap-in” Select “Group Policy” and click “Add”
    Select Group Policy Object” Click “Finish
    Add Standalone Snap-in” Select “Close”
    “Add/Remove Snap-in” Click “OK”

    At “console1” expand “Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components >” click on “Windows Update” and double click on “Configure Automatic Updates” on the right.

    At “Configure Automatic Updates” select “Enable” and in the first dropdown menu select “Notify for download and notify for install”

    You can change is the amount of time between the nagging popup. There is no way to completely remove this popup if you are doing scheduled updates.
    --------------------------------------------------------------------------------------------------------
    If the status is set to Enabled, Automatic Updates will not restart a computer automatically during a scheduled installation if a user is logged in to the computer. Instead, Automatic Updates will notify the user to restart the computer.

    Be aware that the computer needs to be restarted for the updates to take effect.

    If the status is set to Disabled or Not Configured, Automatic Updates will notify the user that the computer will automatically restart in 5 minutes to complete the installation.

    Note: This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.
     
  9. devil_himself

    devil_himself

    Joined:
    Apr 7, 2007
    Messages:
    4,910
  10. gurutech

    gurutech Thread Starter

    Joined:
    Apr 23, 2004
    Messages:
    2,960
    Thanks for the link! It looks like it only applies to SP1 and XP though... I have SP2, and I only got as far as the "Windows" key. I manually added the WindowsUpdate and AU sub-keys, and added the NoAutoRebootWithLoggedOnUsers and set the value to 1, as suggested in the KB. We'll see what happens next time "Patch Tuesday" comes around!
     
  11. ozrom1e

    ozrom1e

    Joined:
    May 15, 2006
    Messages:
    11,849
    This may be illegal here as per the rules, I think it is under the Hacking thing. But if you did a Google search for Disable automatic reboot after Windows Updates I am sure you will find something.
     
  12. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/584114

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice