1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Disable Google Autocomplete

Discussion in 'Web & Email' started by aoeu, Mar 10, 2011.

?

How to you feel about google instant?

  1. I love/like it.

    2 vote(s)
    66.7%
  2. I hate it!

    0 vote(s)
    0.0%
  3. I hate it, along with auto-complete

    1 vote(s)
    33.3%
Thread Status:
Not open for further replies.
Advertisement
  1. aoeu

    aoeu Thread Starter

    Joined:
    Mar 10, 2011
    Messages:
    4
    Hello everyone, I use Firefox 4.0 rc (release condition) and I am wondering whether anyone here knows of a way to disable the search-box auto-complete at google.com/*

    through: - user scripts (some were outdated, so doesn't work with google 2011 or firefox 4)
    - firefox options
    - google options
    - any other way

    Thank you in advance for any insights!
     
  2. Ziggy1

    Ziggy1

    Joined:
    Jun 17, 2002
    Messages:
    2,532
    Click the search settings you will find it... Look top right of google page
     
  3. aoeu

    aoeu Thread Starter

    Joined:
    Mar 10, 2011
    Messages:
    4
    I have already checked the settings -- it allows you to turn off "instant search" (which turns back on after a while) but NOT auto-complete.
    Google disabled the option to turn off auto-complete a few years ago, to many users' angst...
    But, thanks for trying. : )
     
  4. valis

    valis Moderator

    Joined:
    Sep 24, 2004
    Messages:
    67,509
  5. Ziggy1

    Ziggy1

    Joined:
    Jun 17, 2002
    Messages:
    2,532

    well, not sure I agree, I turn off the search box's auto complete on my Ipad because it makes the keyboard drop down repeatedly, so not sure why it is coming back on for you?

    the browser also has autocomplete, or as in FF on advanced General... search for "Text...." ?
     
  6. Deke40

    Deke40

    Joined:
    Jun 27, 2002
    Messages:
    5,556
    Here is the results I get after turning off "instant search" before and after. I know this is simple but if you don't save the Google cookie after you make the changes and have some kind of cookie cleaner the setting will go back to the default.
     

    Attached Files:

  7. aoeu

    aoeu Thread Starter

    Joined:
    Mar 10, 2011
    Messages:
    4
    Thank you, everyone for your suggestions! : )
    >>Deke40: Yes, the instant-search part can be solved with setting an exception for the google cookie.
    >>valis: google adv. search does seem to do the trick, although it's interface is not exactly minimalist... I guess I just have to get used to it.

    In any case, now I'll be left inviolate by google's haphazard auto-complete -- Still hope that Google will give users more choices though.
     
  8. Noyb

    Noyb Trusted Advisor

    Joined:
    May 25, 2005
    Messages:
    19,742
  9. Deke40

    Deke40

    Joined:
    Jun 27, 2002
    Messages:
    5,556
    Good tip Noyb.

    After posting on here a buddy online informed me of that link. I changed the url on my shortcut to it
    and did away with the saved Google cookie.

    Thanks as my memory sucks and I forgot about this thread.
     
  10. aoeu

    aoeu Thread Starter

    Joined:
    Mar 10, 2011
    Messages:
    4
    Thanks a lot! I wonder why it didn't work before...
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/985230