Disk drive will not show up!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

tetris556

Thread Starter
Joined
Jan 1, 2011
Messages
7
I have just gotten a new and very powerful computer for Christmas, but the disk drive doesn't appear on the My Computer menu. I have checked the bios, and it is there, but Windows 7 doesn't seem to find it. I have Windows 7 64 bit and a Gigabyte 870A-UD3 motherboard.
 

daz1

Banned
Joined
Nov 4, 2006
Messages
2,664
assuming the comp is acrually working/running?

start click my computer organise layout tick menu detail navigation then folder/search options reset defaults on both options if no good go back to that point untick hide drives


if comp not actually working ignore above !!
 
Joined
Jul 22, 2006
Messages
8,450
Control Panel/Folder Options/View
Uncheck "Hide empty drives."
 

tetris556

Thread Starter
Joined
Jan 1, 2011
Messages
7
I tried both of these, and they didn't work :/

The computer runs beautifully otherwise.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
80,955
Start - Computer. What does show up? Attaching a screen shot of that Windows Explorer window would be nice.

What, if any, warnings or errors are there in Device Manager? What is listed in Device Manager under Disk drives?
 

tetris556

Thread Starter
Joined
Jan 1, 2011
Messages
7
In MY Computer I see, my USB drives, my 2 Hard Drives, and that's it. There are no warnings in my Device Manager either.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
80,955
In MY Computer I see, my USB drives, my 2 Hard Drives, and that's it.
That's several disk drives. That doesn't match well with "but the disk drive doesn't appear." :confused:
 
Joined
Jun 16, 2005
Messages
116
are you talking about a new hard drive that's not formatted? if you are then you may need to go into disk management and format it. To do this right click on 'Computer' either on your desktop or by clicking Start and right clicking on Computer in the right hand column. In the right click menu is an option to 'manage' click this and then click on Disk Management under 'Storage' this will then list all the drives on your computer, at which point if you new drive is listed it may appear as something like 'not initialized', right click on the drive and it should give you the option to format, then all you need to do is follow the prompts.
hope this helps
Michael
 

tetris556

Thread Starter
Joined
Jan 1, 2011
Messages
7
Sorry, when I say hard drive, I mean what you store data on, when I say disk drive, I mean what I put DVDs and CDs in.
 

jrbuergel

Jim
Joined
Jan 17, 2004
Messages
806
You could check the CD/DVD optical disk drive power and data connections. If you put a CD disk in your drive, then look in the my computer for it showing ? If you see this drive listed in the device manager, then try re-installing the device driver for it.
 

tetris556

Thread Starter
Joined
Jan 1, 2011
Messages
7
The drive is not listed in device manager, or the controllers. The bios read it though, so I can still use my ubuntu live disk.
 

davehc

David
Retired Trusted Advisor
Joined
Oct 4, 2006
Messages
2,059
Open the Control Panel - Admiistrative tools - Computer Management - Disk management. You should see the dvd dive there. If it has not a letter assigned to it, give it the next sequential one (E?), and see if that can sort it out.
 

tetris556

Thread Starter
Joined
Jan 1, 2011
Messages
7
I checked disk management, and I found a Drive without a letter called system reserved, but that wasn't it.
 
Joined
Jun 16, 2005
Messages
116
if this is what I think it is this is a known problem with windows that goes back to XP. For some reason some of the CD rom filters in the registry get corrupted, which means that the CD/DVD drive doesn't show up in Windows Explorer.
The work round is to edit the registry, if you're feeling brave; if you navigate to this setting and delete the Upper Filter setting and the Lower Filter, if it's there, and reboot you should get your optical drive back

Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
Key Name: {4D36E965-E325-11CE-BFC1-08002BE10318}
Value Data: [Delete All Value Data from UpperFilters and LowerFilters]
Note: Do not delete the Key or the Multi-String Values. Delete only the data values.
Exit Registry and Reboot

hope this helps
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top